V2EX 首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Node.js
Express
PPA for Ubuntu
ppa:chris-lea/node.js
V2EX  ›  Node.js

VScode 怎么才能有语法高亮?

  •  1
     
  •   lneoi · 328 天前 · 9874 次点击
    这是一个创建于 328 天前的主题,其中的信息可能已经有所发展或是发生改变。
    之前在其他电脑装了个 vscode ,语法显示蛮全。
    换了一台电脑,重新安装了个 vscode 。打开 js 文件,就剩下几个 var if 之类关键字高亮了。 exports 什么的都是灰色。
    随便乱装了两个 js 插件也没效果。
    47 回复  |  直到 2017-10-22 10:55:04 +08:00
        1
    alqaz   328 天前   ♥ 1
    一个插件不行,就两个,两个不行,就三个。以此类推。
        2
    murmur   328 天前
    这不是你的锅, vscode 这种轻型记事本的设计就是只能识别 js 规范的关键字, exports 明显是 node 自己加的
    如果你用 webstorm 就能加的五颜六色了
    另外 vs 的默认颜色怎么说呢。。除了蓝色就是橘红色
        3
    zzuieliyaoli   328 天前   ♥ 1
    用这个 Babel ES6/ES7
        4
    xcatliu   328 天前   ♥ 1
    看下右下角的文件类型,是不是 js
        5
    XueSeason   328 天前   ♥ 2
    @murmur 不懂不要瞎说。
        6
    starvedcat   328 天前   ♥ 1
    试试 settings sync 这个插件
        7
    jsq2627   328 天前   ♥ 2
    @murmur vscode 是有完整 js 高亮、语义级补全、调试、 lint 功能的,堪称轻量编辑器里的战斗机
        8
    itqls   328 天前   ♥ 1
    我下了一堆插件,还是有的不亮
        9
    loshine1992   328 天前   ♥ 1
    @murmur 不要在自己不懂的领域随便评论。
        10
    zhidian   328 天前   ♥ 2
    每次点进这个节点看到这屎一样的配色就难受……
        11
    yangg   328 天前 via iPhone   ♥ 2
    换个主题,有的主题不支持 es6 的 class
        12
    murmur   328 天前
    @XueSeason 呵呵, webstrom 、阿童木、 asc 我都用过,不讨论爆改插件的情况, vsc 默认 module.export 是不染色的,默认染色最漂亮的我认为是 atom ,其次 webstorm , vsc 默认的加亮太保守了,改了插件我就不知道了,因为 ws 我是订阅了的
    @jsq2627 你确定路径不完整以及 node_modules 里的东西他能扫出来么?
        13
    murmur   328 天前
    @loshine1992 呵呵,什么叫不懂什么叫懂呢?我的哲学是能默认就默认, IDE 好的绝对不会委屈自己用记事本
        14
    ivechan   328 天前   ♥ 2
    楼上无脑喷什么 vscode 啊? 看个标题就回复?
    楼主说的是之前用 vscode 的时候是有高亮的, 换了台电脑重装了 vscode 才没有的.

    再次强调, 楼主说的是 vscode 语法高亮蛮全的, 重装了才没有.
    直接进来说 vscode 就是没有,回了三个帖子, 跟其他人喷了起来, 却完全无视楼主的话.
    大写的服.
        15
    murmur   328 天前
    @ivechan 是么?我办公电脑上至少用了 1 年 vsc 了,我可不觉得 vsc 默认的语法高亮很全,他只高亮了常用关键字而已,我用的版本很新了,已经支持 react 的 jsx 了,而且没装插件
    atom 和 webstorm 可是能区分常量、函数、数字、字符串的颜色的,看着明显舒服的多
    我当然知道 vsc 有调试的功能,我也知道 vsc 启动速度可以碾压 atom ,但是他默认高亮太单调这个能否定么?
    综上我不认为这是重装电脑的问题,默认 vsc 加亮就太单调,要么是楼主记忆有问题,要么是他自己加载了什么插件忘了
        16
    murmur   328 天前   ♥ 1
    最后回一帖
    我自己来打脸
    换个颜色主题就可以了 默认的主题真的只高亮 var if 这些。。但是 export 算关键字就连 notepad++都能高亮出来
    exports 是什么关键字?我以为楼主问的是 module.export 这个导出
        17
    hronro   328 天前   ♥ 2
    @murmur
    jsx 一年前就支持了,你这算新么
    另外 vs code 的语法高亮确实是最近才更新过的,楼主的原因可能他后面下的那个版本比较旧
        18
    jsq2627   328 天前 via iPhone   ♥ 2
    @murmur 今天还刚刚把公司项目主要编辑器切到 vscode ,记忆非常深刻的。在 html/vue 里的 js 补全不会补全 require ,在纯 js 文件的补全是可以扫 node_modules 补全 import/require 的。
    vscode 更新步伐比较快,最近 1.8 才支持在 html 内补全 js/css 的,我觉得有可能是你用的时候并没有补全 require 的功能。
    另外建立 jsconfig.json 可能也会有影响。

    至于楼主说的高亮问题,能不能配个图啊。。尽管我觉得 vscode 的高亮稍微单调点,但也不至于不可用呀。

    以前我也用 webstorm 写 angular 一年有余,其实论前端编辑器最强大的还是 webstorm 了。不过 jetbrains 系列 ide 的第三方扩展生态不是很成气候(可能因为自身功能太完善了吧),感觉缺乏活力,以及 ide 过重,后来转了 vscode 。
        19
    qfdk   328 天前 via Android   ♥ 1
    @jsq2627 以前可以自动下载配置文件,现在不可以了,现在必须得下 typings
        20
    lneoi   328 天前
    @xcatliu 右下角是 JavaScript 。
        21
    lneoi   328 天前
    @alqaz 不知道具体要用哪个....以前的不用装都能用..
        22
    lneoi   328 天前
    @murmur 是..就是这个。还有其他,反正基本全白了..昨天有截图,我去找找
        23
    lneoi   328 天前
    @hronro 我用软件里面的检查更新,但没提示有新版本
        24
    lneoi   328 天前
    @jsq2627
    http://ww4.sinaimg.cn/large/a15b4afegw1fb8hy96rcpj20aq0dogml
    这是新安装的,其他文件打开,也基本就这几个会亮了。好像 nodej 的一些关键字不会亮。
        25
    lneoi   328 天前
        27
    wolffn   328 天前
    这是颜色主题的原因, lz 换一个 color theme

    推荐 Atom OneDark
        29
    wolffn   328 天前   ♥ 1
    给 lz 截图了,不知道怎么发出来。。。求指导如何发截图。。。。
        30
    lneoi   328 天前
    @wolffn 好像还真的是....因为笔记本这黑色太暗了,所以调了下,但后来忘记有调过了
        31
    lneoi   328 天前
    @wolffn 我就记得会自动识别新浪的地址,地址直接贴出来就行,其他还有什么网盘能用就不懂了。
        32
    wolffn   328 天前
        33
    wolffn   328 天前
    @lneoi 没管用。。。是不是得加点啥
        34
    lneoi   328 天前
    http://x.mouto.org/wb/
    @wolffn 这个网盘试试,直接传新浪的。不过刚刚第二张图,里面有带 jpeg ,好像给截断了,贴出来的裂了,我也不懂怎么搞..
        36
    lneoi   328 天前
    @wolffn 还是没显示成.. 好像这主题配色显示更少了点。我去找个显示又多又好看的来
        39
    lneoi   328 天前
        40
    hronro   328 天前   ♥ 1
        41
    hronro   328 天前
    语法高亮还是可以的哈
        42
    shunia   328 天前
    看完回复眼睛瞎了,现在盲打中,怎么破,在线等,挺急的.
        43
    lrh3321   328 天前
    它是想向你推荐自家的 Typescript 呢
        44
    thinkloki   328 天前
    @hronro 你这个看着很爽怎么搞得。
        45
    Vizogood   327 天前 via Android
    @murmur vsc 不是定位前端开发者么
        46
    hronro   326 天前
    @thinkloki
    vsc 自带的语法确实不太好,我用了 Sublime Babel 插件来增强 vsc 的语法。主题用的是 Material Ocean Next Theme +
        47
    missmimimi   32 天前
    @zzuieliyaoli 装了你说的这个插件还是不行呢
    DigitalOcean
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   2626 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.0 · 97ms · UTC 07:28 · PVG 15:28 · LAX 23:28 · JFK 02:28
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1