› MySQL 5.5 Community Server
› MySQL 5.6 Community Server
› Percona Configuration Wizard
› XtraBackup 搭建主从复制
Great Sites on MySQL
› Percona
› MySQL Performance Blog
› Severalnines
推荐管理工具
› Sequel Pro
› phpMyAdmin
推荐书目
› MySQL Cookbook
MySQL 相关项目
› MariaDB
› Drizzle
参考文档
› http://mysql-python.sourceforge.net/MySQLdb.html
Livid
396.81D
543.86D
V2EX  ›  MySQL

关于用了 Percona Configuration Wizard 生成的配置文件之后造成的 Percona Server 启动问题

  •  
  •   Livid ·
    PRO
    · Oct 13, 2014 · 5203 views
    This topic created in 4368 days ago, the information mentioned may be changed or developed.

    Percona Server 5.6 在 Ubuntu Server 上安装了之后,是没有主配置文件 /etc/mysql/my.cnf 的。所以一种比较科学的做法就是使用 Percona 官方的配置文件生成工具 Percona Configuration Wizard ,根据服务器的具体情况生成一个。

    但是在使用了这个新的配置文件之后,你可能会遇到一个问题就是,用 /etc/init.d/mysql 启动 Percona Server 时总是报告 fail:

    # /etc/init.d/mysql start
     * Starting MySQL (Percona Server) database server mysqld                [fail]
    

    同时如果你用 /etc/init.d/mysql status 检查运行状态时,也总是返回 Percona Server 没有运行:

    # /etc/init.d/mysql status
     * MySQL (Percona Server) is stopped.
    

    而实际上 Percona Server 在这个时候是已经启动起来了的,并且也可以完全正常地提供服务。

    Google 了一下之后找到了这个:

    https://bugs.launchpad.net/percona-server/+bug/1199395

    造成这个问题的原因是 /etc/mysql/debian.cnf 中定义的 socket 文件地址和 Percona Configuration Wizard 生成的 /etc/mysql/my.cnf 中的不一样,于是造成启动脚本无法正确检测 Percona Server 的运行状态。

    解决方法就是将 /etc/mysql/debian.cnf 中的 socket 的值修改到和 /etc/mysql/my.cnf 的一样就可以了。

    No Comments Yet
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   1039 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 40ms · UTC 18:15 · PVG 02:15 · LAX 11:15 · JFK 14:15
    ♥ Do have faith in what you're doing.