V2EX 首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Android

自己开发的应用,为什么第一版可以安装,新版之后就不能安装?

  •  
  •   scarlex · 2015-07-24 16:05:05 +08:00 · 1041 次点击
    这是一个创建于 795 天前的主题,其中的信息可能已经有所发展或是发生改变。
    在 gradle 中改了 versionCode 和 versionName 之后就不能安装了?只提示了「应用未安装」,然后就没其他提示了。

    版本升级还需要修改其他地方吗?
    6 回复  |  直到 2015-07-28 22:49:47 +08:00
        1
    dullwit   2015-07-24 16:08:22 +08:00   ♥ 1
    签名?
        2
    Karblue   2015-07-24 16:25:29 +08:00   ♥ 1
    通过adb install 安装就可以知道具体原因了。很有可能是签名问题
        3
    scarlex   2015-07-24 16:35:35 +08:00
    @dullwit
    @Karblue
    签名有问题的话 Google Play 上架的时候会有提示的吧?我更新之后上架都没问题。
        4
    Bown   2015-07-24 16:41:02 +08:00   ♥ 1
    如2L说的,apk下下来,在电脑上用adb install来装,看看返回具体的错误原因是啥
        5
    scarlex   2015-07-24 16:47:56 +08:00
    @Bown
    好吧,我知道了。果然是 Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES] 。
    应该是我上架的时候用了签过名的 apk,但上传网盘的时候传了其他版本。

    感谢
        6
    fireking   2015-07-28 22:49:47 +08:00
    应该是签名问题
    DigitalOcean
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   1854 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.7.5 · 66ms · UTC 10:53 · PVG 18:53 · LAX 03:53 · JFK 06:53
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1