首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

很想问大家,你们编译安装源码的时候,遇到依赖的依赖的依赖,心里面有没有一万只羊驼在奔跑……

  •  
  •   Daddy · 2015-09-17 00:54:42 +08:00 · 862 次点击
    这是一个创建于 982 天前的主题,其中的信息可能已经有所发展或是发生改变。

    就比如 wget 吧,自带的版本太低,想升级一下,以为这货会很简单,没想到这么麻烦,依赖又依赖又依赖又依赖,算了,放弃升级了……

    都被搞混了,简直就是一万只羊驼在跑呀跑…… (・´ェ`・)

    第 1 条附言  ·  2015-09-17 13:15:29 +08:00
    23333 ,查一下,发现编译安装成功 wget 最新的 1.16.3 ……
    前天好气馁啊, wget --> gnutls --> nettle ---> pkg-config ---> glib-html
    N 层依赖一直往下层层编译,看着好像也没错,可版本号就是不更新,无语死了

    今天重查了下,发现版本号更新了…… 我 X
        1
    ryd994   2015-09-17 06:56:35 +08:00 via Android
    所以包管理啊……
    源码编译活该
        2
    qinglangee   2015-09-17 12:35:48 +08:00
    包管理器为啥不用, 自己作死
    有本事自己写一个 wget, 用别人写好的多 low
        3
    Daddy   2015-09-17 13:01:27 +08:00
    @ryd994 @qinglangee 我说的是 VPS 呀
        4
    Daddy   2015-09-17 13:09:54 +08:00
    23333 ,奥特曼了,居然编译安装好最新 wget 1.16.3 ……
    当时查版本号还是老版本,以为还没搞定,气馁了
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   1784 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 15ms · UTC 07:58 · PVG 15:58 · LAX 00:58 · JFK 03:58
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1