V2EX 首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Java

Java 版本兼容疑问

  •  
  •   qiyuey · 125 天前 · 1014 次点击
    这是一个创建于 125 天前的主题,其中的信息可能已经有所发展或是发生改变。
    像 fastjson 这种含有 Java 8 ,如: LocaDate 的代码,是怎样编译出 minor.major 49 的 class 文件的?
    直接使用-target 好像不可以吧?
    7 回复  |  直到 2017-03-21 14:02:59 +08:00
        1
    unionx   125 天前
    maven 的 pom.xml 里面设置 maven-compiler-plugin 的 source 和 target 参数
        2
    snnn   125 天前 via Android
    这样在低版本的 JRE 上能跑?
        3
    slixurd   125 天前
    1.1.x 都是用 JDK 1.6 来编译的...
    现在已经改成了 1.8.0_25
    如果不是因为之前的漏洞问题,本来不想升级的
    用高版本编译低版本的包很容易就挂了...
    例如非常经典的 ConcurrentHashMap 问题.....
        4
    SoloCompany   125 天前
    你看错了吧

    <properties>
    <junit.version>4.11</junit.version>
    <gpg.skip>true</gpg.skip>
    <javadoc.skip>false</javadoc.skip>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <jdk.version>1.5</jdk.version>
    </properties>

    项目仅仅是用了 jdk 8 的 api 并没有使用 java 8 语法
    当然可以 target 到 1.5 了
    然后你在代码内部完全可以自己判断 java 版本去加载不同的支持部分
        5
    qiyuey   124 天前
    @SoloCompany 像 LocalDate 这种是可以的,但是像 lambda 表达式这种是不行的,是这个意思吗?
        6
    SoloCompany   124 天前
    @qiyuey #5 你要区分一下什么是 API 什么是语言特性, API 实质就是类库而已,比如 joda time 本来就是一个库,内置到 jdk 8 之后只不过换了个名称空间
        7
    qiyuey   124 天前
    @SoloCompany 明白了 感谢感谢
    DigitalOcean
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   500 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.7.5 · 53ms · UTC 22:41 · PVG 06:41 · LAX 15:41 · JFK 18:41
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1