首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  中州韻

Build Squirrel has some error on macOS

  •  1
     
  •   sunzhenyucn · 2018-04-20 11:27:43 +08:00 · 2512 次点击
    这是一个创建于 599 天前的主题,其中的信息可能已经有所发展或是发生改变。

    The Build Environment:

    • macOS version: macOS Hign Sierra 10.13.4
    • XCode Command Line Tools version: 9.3 Update time: Apr 2, 2018
    • CMake version: 3.11.1
    • Boost version: 1.67.0_1
    • Git version: 2.15.1

    The error content:

    cp -R thirdparty/src/gtest/include/gtest thirdparty/include/
    cp thirdparty/src/gtest/build/libgtest*.a thirdparty/lib/
    /Library/Developer/CommandLineTools/usr/bin/make -C librime -f Makefile.xcode release
    cmake . -Bxbuild -GXcode -DBUILD_STATIC=ON -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON
    CMake Error:
      Xcode 1.5 not supported.
    
    
    CMake Error: Could not create named generator Xcode
    

    The error content screenshot:

    rime-error-screenshot.jpg

    If anyone know how fix this error, please tell me, thanks!!!

    2 回复  |  直到 2018-10-16 12:16:08 +08:00
        1
    meta   2018-07-21 15:26:23 +08:00
    xcode 指错了地方,可以用 xcode-select 重新设定一下,例如 xcode-select -switch /Application/Xcode.app
        2
    jackytang520   2018-10-16 12:16:08 +08:00
    我和编译报的错一样,只装了 XCode Command Line Tools 不行,需要把 Xcode 全部下载安装,好几个 g,要点时间
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2611 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 14:32 · PVG 22:32 · LAX 06:32 · JFK 09:32
    ♥ Do have faith in what you're doing.