V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
The Go Programming Language
http://golang.org/
Go Playground
Go Projects
Revel Web Framework
beego
jhwangpin
V2EX  ›  Go 编程语言

我想搭个开源论坛,找到一个基于 GO 的,但按步骤下来卡在 DEP 下载依赖的那部

  •  
  •   jhwangpin · 2018-05-18 09:50:16 +08:00 · 1585 次点击
    这是一个创建于 1466 天前的主题,其中的信息可能已经有所发展或是发生改变。

    开源论坛地址 https://github.com/shen100/golang123 有一步是下载依赖,工程里面自带的 2 个 Gopkg.lock 和 Gopkg.toml 在开源里已经自带了,但按步骤执行 dep ensure 一直卡着不动是为什么,请高手赐教。

    [[email protected] golang123]$ dep ensure Warning: the following project(s) have [[constraint]] stanzas in Gopkg.toml:

    github.com/asaskevich/govalidatorgithub.com/gin-contrib/sessions

    However, these projects are not direct dependencies of the current project: they are not imported in any .go files, nor are they in the 'required' list in Gopkg.toml. Dep only applies [[constraint]] rules to direct dependencies, so these rules will have no effect.

    Either import/require packages from these projects so that they become direct dependencies, or convert each [[constraint]] to an [[override]] to enforce rules on these projects, if they happen to be transitive dependencies.

    7 条回复    2018-05-18 10:56:11 +08:00
    gesse
        1
    gesse  
       2018-05-18 09:59:55 +08:00
    这个不是应该直接开 issue 或者去他们自己的论坛问吗?
    jhwangpin
        2
    jhwangpin  
    OP
       2018-05-18 10:09:37 +08:00
    @gesse 昨天就去那边回了,还加了他们的群,没人理,估计是嫌我不专业,是个 GO 新手。。
    dlpliu
        4
    dlpliu  
       2018-05-18 10:24:09 +08:00
    github.com/asaskevich/govalidatorgithub.com/gin-contrib/sessions 这两个包没有引用但是在 Gopkg.toml 标记引用了。目测是这个配置文件 git 上的版本问题。dep 应该有可以扫代码,重新生成这个文件的功能吧。我用的是另一个包管理工具 glide。
    gesse
        5
    gesse  
       2018-05-18 10:48:08 +08:00
    进入全新的 git 目录
    执行
    git submodule update --init --recursive 这之类的命令
    jhwangpin
        6
    jhwangpin  
    OP
       2018-05-18 10:55:24 +08:00
    @dlpliu 依赖库是看 LOCK 文件还是看 TOML 文件的,我想自己用 GO GET 一个个去下
    jhwangpin
        7
    jhwangpin  
    OP
       2018-05-18 10:56:11 +08:00
    @gesse 这招貌似不行,这项目用的是 DEP 来管理依赖包的。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2803 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 12:08 · PVG 20:08 · LAX 05:08 · JFK 08:08
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.