首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
阿里云
i386
V2EX  ›  macOS

Mojave 的 AppStore 不能用

  •  
  •   i386 · 2018-06-12 19:11:40 +08:00 · 6850 次点击
    这是一个创建于 658 天前的主题,其中的信息可能已经有所发展或是发生改变。

    账号是美区,AppStore 登录后还是被放到中区。 下载 App 时,提示需要切换到美区,点“切换”直接弹出不能连接 AppStore,怎么重试都没用。退出 /重新登录 AppStore,退出 /重新登录 iCLoud 都没用。

    没人遇到吗?

    18 条回复    2018-12-25 16:28:40 +08:00
    imydou
        1
    imydou   2018-06-12 19:42:20 +08:00   ❤️ 1
    善用搜索,看我发帖记录
    i386
        2
    i386   2018-06-12 20:14:02 +08:00
    太感谢了,翻了几页没看到,我以为我是第一个掉坑里的。
    bao3
        3
    bao3   2018-06-12 20:15:33 +08:00 via iPhone
    develop 版本就不要问了……本来就未知残疾版本,不光 app store 不能用,蓝牙也可能会失败,动不动会转圈圈,跑大 app 会内存错误,偶尔键盘连击重启就好。
    用着残疾版本就要淡定……
    scomper
        4
    scomper   2018-06-12 21:22:29 +08:00
    brew install mas

    mas upgrade
    imydou
        5
    imydou   2018-06-12 22:27:21 +08:00
    @scomper #4

    机智如你

    OSError: [Errno 13] Permission denied

    Do not report this issue to Homebrew/brew or Homebrew/core!


    Error: You are using macOS 10.14.
    We do not provide support for this pre-release version.
    You may encounter build failures or other breakages.
    Please create pull-requests instead of filing issues.

    Error: You are using macOS 10.14.
    We do not provide support for this pre-release version.
    You may encounter build failures or other breakages.
    Please create pull-requests instead of filing issues.
    imydou
        6
    imydou   2018-06-12 22:31:06 +08:00
    @scomper #4 还以为你开玩笑,居然是真的。
    HanningWu
        7
    HanningWu   2018-06-12 22:39:28 +08:00
    @scomper 想问一下 macOS 10.14 下 HomeBrew 能正常使用吗?
    scomper
        8
    scomper   2018-06-13 07:11:03 +08:00
    @HanningWu 能,需要 Xcode beta 环境
    scomper
        9
    scomper   2018-06-13 07:15:24 +08:00   ❤️ 1
    HanningWu
        10
    HanningWu   2018-06-13 11:46:21 +08:00
    @scomper 在 macOS 10.14 下,终端 shell 环境下都没出什么问题?
    zeo
        11
    zeo   2018-06-13 15:22:07 +08:00
    我就是美区 ID,没有遇到任何问题呀。
    lesswest
        12
    lesswest   2018-06-14 10:07:16 +08:00   ❤️ 1
    defaults delete com.apple.appstore.commerce
    syhily
        13
    syhily   2018-06-17 03:18:34 +08:00
    @scomper 感謝截圖,知道一個叫做 mas 的工具。
    syhily
        14
    syhily   2018-06-17 03:18:55 +08:00
    macOS 升級到 10.14 後,Homebrew 方式安裝的 Typescript 升級失敗,原因是 node.js 升級失敗。node 手動升級失敗,原因是 ImportError: No module named zlib。於是重灌 Python3,結果 pip3 丟失。

    被逼無奈下 brew doctor 一發移除一堆標頭檔案,python3 OK,node OK。

    天知道我只想升級 TS
    VVVVVEX
        15
    VVVVVEX   2018-09-18 15:21:05 +08:00
    怎么解决啊?
    VVVVVEX
        16
    VVVVVEX   2018-09-18 15:23:24 +08:00
    defaults delete com.apple.appstore.commerce
    可破
    fefffff
        17
    fefffff   2018-11-21 09:59:50 +08:00
    https://stackoverflow.com/questions/52522565/git-is-not-working-after-macos-mojave-update-xcrun-error-invalid-active-devel
    「 What fixed it for me was going here https://developer.apple.com/download/more/ and downloading Command Line Tools (macOS 10.14) for Xcode 10 and then installing it manually.」
    当我解决了终端报错问题后 App Store 也能打开了~
    yundanfengqing
        18
    yundanfengqing   2018-12-25 16:28:40 +08:00
    改 DNS 改证书 全局 faqing 装 mas 清除 cookies 清除 配置文件 都没有用 很郁闷
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3251 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 13:35 · PVG 21:35 · LAX 06:35 · JFK 09:35
    ♥ Do have faith in what you're doing.