V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
jhwangpin
V2EX  ›  PHP

PHP7.2 加参数 oci8 编译时不支持 LDAP?

  •  
  •   jhwangpin · 2018-09-07 09:34:41 +08:00 · 1487 次点击
    这是一个创建于 1354 天前的主题,其中的信息可能已经有所发展或是发生改变。

    CENTOS 6.5 ORACLE 11G 客户端 PHP5.6 升级到 7.2 编译参数如下: ./configure --prefix=/usr/local/php
    --with-config-file-path=/usr/local/php/etc --with-bz2 --with-curl
    --enable-ftp --enable-sockets --disable-ipv6 --with-gd
    --with-jpeg-dir=/usr/local --with-png-dir=/usr/local
    --with-freetype-dir=/usr/local --enable-gd-native-ttf
    --with-iconv-dir=/usr/local --enable-mbstring --enable-calendar
    --with-gettext --with-libxml-dir=/usr/local --with-zlib
    --with-oci8=shared,instantclient,/usr/lib/oracle/11.2/client64/lib
    --enable-dom --enable-xml --enable-fpm --with-libdir=lib64 --enable-bcmath --with-ldap

    configure 无问题,make 时报错如下: 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:30 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/oracle/11.2/client64/ldap.h:97:1: 警告:“ LBER_ENUMERATED ”重定义 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:27 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/lber.h:88:1: 警告:这是先前定义的位置 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:30 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/oracle/11.2/client64/ldap.h:98:1: 警告:“ LBER_SEQUENCE ”重定义 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:27 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/lber.h:89:1: 警告:这是先前定义的位置 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:30 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/oracle/11.2/client64/ldap.h:99:1: 警告:“ LBER_SET ”重定义 在包含自 /root/php-7.2.9/ext/ldap/php_ldap.h:27 的文件中, 从 /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/lber.h:90:1: 警告:这是先前定义的位置 In file included from /root/php-7.2.9/ext/ldap/php_ldap.h:30, from /root/php-7.2.9/ext/ldap/ldap.c:39: /usr/include/oracle/11.2/client64/ldap.h:183: 错误:‘ struct berval ’重定义 /root/php-7.2.9/ext/ldap/ldap.c: 在函数‘ zm_startup_ldap ’中: /root/php-7.2.9/ext/ldap/ldap.c:287: 错误:‘ LDAP_EXOP_START_TLS ’未声明(在此函数内第一次使用) /root/php-7.2.9/ext/ldap/ldap.c:287: 错误:(即使在一个函数内多次出现,每个未声明的标识符在其 /root/php-7.2.9/ext/ldap/ldap.c:287: 错误:所在的函数内也只报告一次。) /root/php-7.2.9/ext/ldap/ldap.c:288: 错误:‘ LDAP_EXOP_MODIFY_PASSWD ’未声明(在此函数内第一次使用) /root/php-7.2.9/ext/ldap/ldap.c:289: 错误:‘ LDAP_EXOP_REFRESH ’未声明(在此函数内第一次使用) /root/php-7.2.9/ext/ldap/ldap.c:290: 错误:‘ LDAP_EXOP_WHO_AM_I ’未声明(在此函数内第一次使用) /root/php-7.2.9/ext/ldap/ldap.c:291: 错误:‘ LDAP_EXOP_TURN ’未声明(在此函数内第一次使用) make: *** [ext/ldap/ldap.lo] 错误 1

    1 条回复    2018-09-07 10:07:31 +08:00
    jhwangpin
        1
    jhwangpin  
    OP
       2018-09-07 10:07:31 +08:00
    解决了,ldap 用 phpize 单独编
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2822 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 12:06 · PVG 20:06 · LAX 05:06 · JFK 08:06
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.