首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
TigerS
V2EX  ›  问与答

Unifi 网络如果访问入户猫?

  •  
  •   TigerS · 245 天前 · 950 次点击
    这是一个创建于 245 天前的主题,其中的信息可能已经有所发展或是发生改变。

    入户猫被设置成了桥接模式,只用于当作一个猫使用,后面接 Unifi 的 USG 猫被设置后只能有一个固定 IP 地址 192.168.100.1 用于管理

    Unifi 部分被设置成了一个 10.0.0.1 的地址

    如何在 Unifi 部分设置让连入 Unifi 的电脑可以访问 192.168.100.1 呢?

    14 回复  |  直到 2019-05-21 12:45:42 +08:00
    GreenVine
        1
    GreenVine   245 天前
    把连光猫的 interface 加上 Masquerade 就可以了
    GreenVine
        2
    GreenVine   245 天前   ♥ 2
    ```
    set service nat rule 5001 description 'Fibre Modem Masquerade'
    set service nat rule 5001 log disable
    set service nat rule 5001 outbound-interface [ethernet-interface]
    set service nat rule 5001 protocol all
    set service nat rule 5001 type masquerade
    ```

    其中把[ethernet-interface]换成你实际接光猫的口,比如 eth1, eth2...等等
    Humorce
        3
    Humorce   245 天前
    路由表
    TigerS
        4
    TigerS   245 天前
    @GreenVine 好像那个猫没办法做这些... 我研究下.
    GreenVine
        5
    GreenVine   245 天前   ♥ 1
    @TigerS 可以的,把 rule 写在 config.gateway.json 里面再 Provision 就可以了
    Danswerme
        6
    Danswerme   245 天前   ♥ 1
    假设路由器连接入户光猫用来拨号的物理接口=eth0,给 eth0 添加一个 192.168.100.2 的 ip 地址,然后防火墙里添加 nat 规则,10.0.0.0/24 去往 192.168.100.1 的动作全部 nat 为 192.168.100.2

    ubnt 没用过,routeros 是这样的:
    ```
    /ip address
    add address
    ```
    Danswerme
        7
    Danswerme   245 天前
    假设路由器连接入户光猫用来拨号的物理接口=eth0,给 eth0 添加一个 192.168.100.2 的 ip 地址,然后防火墙里添加 nat 规则,10.0.0.0/24 去往 192.168.100.1 的动作全部 nat 为 192.168.100.2

    ubnt 没用过,routeros 是这样的:
    ```
    /ip address
    add address=192.168.100.2 interface=eth0
    /ip firewall nat
    add chain=srcnat src-address=10.0.0.0/24 dst-address=192.168.100.1 action=src-nat to-addresses=192.168.100.2
    ```
    Danswerme
        8
    Danswerme   245 天前
    上面失误,添加 ip 地址的命令少输入了子网掩码,正确命令应该是:
    ```
    /ip address
    add address=192.168.100.2/24 interface=eth0
    ```
    bubuyu
        9
    bubuyu   245 天前   ♥ 1
    与 lz 同样的情况,试了一下,综合#2、#7、#8,在#2 的基础上在加上下面一条就可以了(给 WAN1 口配置上一个 IP 地址)。
    set interfaces ethernet eth0 address 192.168.1.2/24
    bubuyu
        10
    bubuyu   245 天前
    补充,我的光猫网段跟 lz 不一样,lz 的话,应该这样:
    set interfaces ethernet eth0 address 192.168.100.2/24
    TigerS
        11
    TigerS   244 天前
    @Danswerme 不需要拨号,入户的是电视光缆,我试试设置 nat 规则

    @bubuyu 是光猫上配置这个 WAN1 口还是在 Ubnt 上配置?
    Danswerme
        12
    Danswerme   244 天前 via Android   ♥ 1
    @TigerS 是在 ubnt 路由器上配置 wan1 口。不需要拨号那就是 dhcp ?
    bubuyu
        13
    bubuyu   244 天前   ♥ 1
    @TigerS SSH 到 USG 上配置
    TigerS
        14
    TigerS   244 天前
    @bubuyu 好的我试试看

    @Danswerme 对 DHCP
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3409 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 27ms · UTC 10:10 · PVG 18:10 · LAX 02:10 · JFK 05:10
    ♥ Do have faith in what you're doing.