首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
vue.js
宝塔
V2EX  ›  Vue.js

vue 与 vuex 明明已经安装了,可为什么还会提示需要安装(如图)?

  •  
  •   manyfreebug · 55 天前 · 1951 次点击
    这是一个创建于 55 天前的主题,其中的信息可能已经有所发展或是发生改变。

    vue 与 vuex 明明已经安装了,可为什么还会提示需要安装(如图)?


    10 回复  |  直到 2019-09-29 09:33:05 +08:00
        1
    bitqiang   55 天前 via Android   ♥ 1
    按照他的命令之行一下?
    package 里面写的是,需要的依赖。并不是你已经装好的依赖…
        2
    manyfreebug   55 天前
    @bitqiang 试过,依然不行。node_modules 里有 vue 与 vuex 了
        3
    GzhiYi   55 天前 via iPhone   ♥ 1
    看看引入方式
        4
    stillyu   55 天前 via iPhone   ♥ 1
    是不是大小写问题,有些文件系统是大小写敏感的

    看提示,只是那一个文件找不到 Vue Vuex,别的文件都能找到,这个文件写的是大写,其他文件都是对的
        5
    manyfreebug   55 天前
    @GzhiYi

    安装 vue 与 vuex:
    ```
    npm install --save vue
    npm install --save vuex
    ```
    <br/>
    然后在 store.js 文件中引入 vue 与 vuex
    <br/>
    ```
    import Vue from "Vue";
    import Vuex from "Vuex";
    ```
        6
    xdaoo   55 天前 via iPhone   ♥ 1
    删掉 node_module 目录,重新 yarn install
        7
    manyfreebug   55 天前
    @stillyu @GzhiYi 果然是大小写错了
        8
    lucky1990   55 天前
    1 楼正解
        9
    f056917   55 天前
    命令行里面输入 vue 看看有没有报错
        10
    shintendo   54 天前
    @f056917 命令行里的 vue 不是 vue 是 vue-cli
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2325 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 12:43 · PVG 20:43 · LAX 04:43 · JFK 07:43
    ♥ Do have faith in what you're doing.