首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
muziling
V2EX  ›  Java

idea maven 真是迷一样的东西,下载的版本不正确

  •  
  •   muziling · 116 天前 · 1351 次点击
    这是一个创建于 116 天前的主题,其中的信息可能已经有所发展或是发生改变。
    org.elasticsearch.client:elasticsearch-rest-high-level-client:7.3.2
    正常依赖的都是 7.3.2 的版本,但我删缓存,maven clean , reimport,pom.xml 只保留这个依赖等手段都试了,始终下载的是 6.8.4 的版本,start.spring.io 新建一个 kotlin 工程然后变成下载 6.8.6, 就是不会下载 7.3.2
    org.elasticsearch:elasticsearch:6.8.4
    org.elasticsearch.client:elasticsearch-rest-client:6.8.4
    org.elasticsearch.plugin:parent-join-client:7.3.2
    org.elasticsearch.plugin:aggs-matrix-stats-client:7.3.2
    org.elasticsearch.plugin:rank-eval-client:7.3.2
    org.elasticsearch.plugin:lang-mustache-client:7.3.2
    5 条回复    2020-03-18 10:28:37 +08:00
    wangsongyan
        1
    wangsongyan   116 天前 via iPhone
    看你贴的 artifactId 都不一致
    jingege
        2
    jingege   116 天前
    感觉是你其他依赖的包里有间接依赖了低版本,导致 maven 最后下载了低版本
    jingege
        3
    jingege   116 天前
    用 mvn dependency tree 试试
    Aresxue
        4
    Aresxue   115 天前
    不一定是 maven 的问题,也有可能是 idea 的问题,把 idea 工程的依赖全部删除, 然后重新拉取。再不行再考虑 maven 的问题, 用 mvn dependency tree > tree.txt 分析下依赖, 看是否有 jar 包对它有间接依赖, 有的话就排除掉
    baozijun
        5
    baozijun   111 天前
    使用(idea 上的) maven dependency helper 插件 查看一下依赖
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4546 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 19ms · UTC 02:43 · PVG 10:43 · LAX 19:43 · JFK 22:43
    ♥ Do have faith in what you're doing.