V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
amiwrong123
V2EX  ›  程序员

maven3.6.1 应该配套使用哪个 idea 版本?

  •  
  •   amiwrong123 · 2020-09-24 09:46:43 +08:00 · 2622 次点击
    这是一个创建于 608 天前的主题,其中的信息可能已经有所发展或是发生改变。

    因为照着视频做的,所以 maven 版本和视频中一样,是 maven3.6.1 。但我的 idea 版本好像不对(我的是 2019.2 ),导致 build 的时候有时候没有对应 class 文件编译出来。(点击右边的 maven 标签,好像那些 maven 的 plugin 都是红色的。而且 setting for new project 总是不起作用,每次新建项目都是 idea 默认 maven,要重新改 maven 成自己的)

    看网友说:IDEA2019.1 + maven3.5 版本的 就能解决上诉问题。不过怕再踩坑,来问问大家是不这样版本就匹配了啊

    第 1 条附言  ·  2020-09-24 13:07:01 +08:00
    https://www.cnblogs.com/chuanqi1995/p/11716058.html

    https://ask.csdn.net/questions/926620

    从网上博客来看,idea 2019.2 确实是有点问题的,但不确定这是不是导致了我帖子中的问题。
    chihiro2014
        1
    chihiro2014  
       2020-09-24 09:52:38 +08:00
    用 idea 自带的就可以了,maven 版本高低并没有什么关系
    xiaowei0823
        2
    xiaowei0823  
       2020-09-24 10:07:51 +08:00
    plugin 都是红色试试点击下右边栏的 Reimport All Maven Projects
    xgfan
        3
    xgfan  
       2020-09-24 10:19:17 +08:00   ❤️ 2
    学习就要用最新版,一边学一边踩坑。
    chendy
        4
    chendy  
       2020-09-24 10:26:50 +08:00
    一般用自带的就行,除非项目用到了后来版本的特性
    amiwrong123
        5
    amiwrong123  
    OP
       2020-09-24 10:41:15 +08:00
    @chihiro2014
    @chendy
    idea 自带的 maven 总是叫什么 bounded(maven),所以 idea 自带的 maven 总是与 idea 自身匹配的呗。

    而且我出现的 build 后编译不出来 class 的问题,是不是就是 maven 与 idea 不匹配导致的呀。
    amiwrong123
        6
    amiwrong123  
    OP
       2020-09-24 10:42:13 +08:00
    @xgfan
    我昨天已经踩了好久坑了,照着视频做,就是有问题。
    xgfan
        7
    xgfan  
       2020-09-24 10:44:43 +08:00
    @amiwrong123
    maven 有走代理或者镜像吗?
    aguesuka
        8
    aguesuka  
       2020-09-24 12:32:30 +08:00 via Android
    pom 文件指定一下 plugin 的 version 试试。
    amiwrong123
        9
    amiwrong123  
    OP
       2020-09-24 13:03:23 +08:00
    @xgfan
    用了镜像的
    <mirror>
    <id>alimaven</id>
    <name>aliyun maven</name>
    <url>http://maven.aliyun.com/nexus/content/groups/public/</url>
    <mirrorOf>central</mirrorOf>
    </mirror>
    aflow
        10
    aflow  
       2020-09-24 13:56:43 +08:00
    花点时间看一下《 maven 实战》,关于 maven 的所有疑问都可以得到解决
    a719031256
        11
    a719031256  
       2020-09-24 16:01:13 +08:00
    什么时候 maven 版本跟 idea 版本挂钩了?我 18 版 idea 还在用 maven3.6 呢
    cway
        12
    cway  
       2020-09-24 16:05:48 +08:00
    这跟 idea 版本没关系
    amiwrong123
        13
    amiwrong123  
    OP
       2020-09-24 20:35:11 +08:00
    @chihiro2014
    @xiaowei0823
    @xgfan
    @chendy
    @aguesuka
    @aflow
    @a719031256
    @cway

    帖子中的问题我解决了,确实不是版本问题,是我 maven 配置文件 xml 标签写错了。

    现在在 test 文件夹下有测试文件,src 文件夹下有源码 java 文件。这里有几个问题,问下各位?
    1. 我修改了 src 中的文件,然后运行 test 文件的方法,发现源码文件对应的 class 文件没有更新,打印结果也没有变。所以只是运行 test 文件不会触发编译吗?
    2. 我右键我的 module,点击 build module xxx (因为是一个项目里又建了个 module ),然后运行 test 文件的方法,发现源码文件对应的 class 文件也没有更新,打印结果也没有变。build 怎么也不会触发编译?
    3. 我打开右边 maven 标签,点击 lifecyle 里面的 compile 后,然后运行 test 文件的方法,发现源码文件对应的 class 文件更新了,打印结果也变了。这个倒是能正常工作,但感觉有点麻烦啊。

    新人向,大佬轻喷
    wybhdxfx
        14
    wybhdxfx  
       2020-09-24 20:54:18 +08:00
    之前用的是最新版 maven,踩过坑,退回 3.6.1 。idea 版本 2019.2.4 自带 maven 好像也是 3.6.1 吧。
    hand515
        15
    hand515  
       2020-09-24 21:08:35 +08:00
    maven3 后各个版本变化都不是很大,兼容还是可以的。
    之前一段时间都用 3.3 也没问题
    keshao
        16
    keshao  
       2020-09-24 22:13:50 +08:00
    版本好像不是特别大的问题,我俩 IDEA maven 的版本都是一样的,所以检查下使用插件还有具体的编译配置,兄弟可以配置下 IDEA 的全局 maven 就可以不需要每次都指定了。
    qwerthhusn
        17
    qwerthhusn  
       2020-09-24 22:18:50 +08:00
    我都不知道我用的 Maven 版本是多少。我本地也没有装 Maven 。。
    因为我用的是 IDEA 自带的 Maven,也没出现过什么问题

    如果需要项目指定 Maven 版本(比如高版本的不支持),可以用 Maven Wrapper 。
    像 gradlew 一样,由项目指定想用的 Maven 版本,这样兼容性更强。。
    EminemW
        18
    EminemW  
       2020-09-25 09:00:13 +08:00 via iPhone
    我一般出问题都是用我自己安装的 maven,换回 idea 自己带就没问题
    amiwrong123
        19
    amiwrong123  
    OP
       2020-09-25 09:38:19 +08:00
    谢谢各位回答啦
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1063 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 38ms · UTC 22:38 · PVG 06:38 · LAX 15:38 · JFK 18:38
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.