V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
forzalianjunting
V2EX  ›  问与答

老哥们, m1 mbp 执行 pod install 一直报错,求助

  •  
  •   forzalianjunting · 324 天前 · 942 次点击
    这是一个创建于 324 天前的主题,其中的信息可能已经有所发展或是发生改变。
    LoadError - dlopen(/Library/Ruby/Gems/2.6.0/gems/ffi-1.14.2/lib/ffi_c.bundle, 0x0009): missing compatible arch in /Library/Ruby/Gems/2.6.0/gems/ffi-1.14.2/lib/ffi_c.bundle - /Library/Ruby/Gems/2.6.0/gems/ffi-1.14.2/lib/ffi_c.bundle


    github 上的很多方法都试过了,还是不行,搞了大半天了
    第 1 条附言  ·  323 天前
    [!] Couldn't determine repo type for URL: `https://cdn.cocoapods.org/`: Invalid ABI specified

    按照大家的方式后,pod install 又报这个问题了,有没有大佬知道怎么解决?
    3 条回复    2021-01-19 17:31:59 +08:00
    jinyang656
        1
    jinyang656  
       324 天前
    装一个 x86 的 ffi
    arch -x86_64 sudo gem install ffi
    BrettD
        2
    BrettD  
       323 天前
    forzalianjunting
        3
    forzalianjunting  
    OP
       323 天前
    @jinyang656 这一步通过了,然后报了另外一个错,能帮忙看下吗
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1995 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 26ms · UTC 16:22 · PVG 00:22 · LAX 08:22 · JFK 11:22
    ♥ Do have faith in what you're doing.