› httpbin - 协议调试工具
› httpstatuses - 协议状态码查询
› httpie - cURL-like tool for humans
Fiddler
MonTubasa
V2EX  ›  HTTP

居然 http 还有 418 这么个状态码

  •  
  •   MonTubasa · Aug 26, 2021 · 4730 views
    This topic created in 1901 days ago, the information mentioned may be changed or developed.

    今天在看 http 协议的时候,忽然瞄到一个 418 状态码

    418 I'm a teapot 服务器拒绝尝试用 “茶壶冲泡咖啡”。

    wtf?这玩意在 developer.mozilla.org 这个网站上显示是所有浏览器兼容,实际上测了一下,就没有哪个浏览器兼容的。 这玩意真震撼我一年, 查了一查,居然还有个 [save418]https://save418.com 这么个网站。 一时不知道说什么好。 话说各位有没有谁知道哪个浏览器现在支持这个状态码的?我想打开看看。

    15 replies  •  2021-08-28 11:44:56 +08:00
    GG668v26Fd55CP5W
    GG668v26Fd55CP5W
    Aug 26, 2021 via iPhone
    3
    我突然想起来有些 nginx 配置示例喜欢用 error_page 418,好像是用来做内部处理,当然用别的错误码可以。

    error_page 418 = @queryone;
    israinbow
    israinbow
    Aug 26, 2021
    5
    可惜的是, Mozilla 没有兼容超文本咖啡壶控制协议.
    DawnMoon
    DawnMoon
    Aug 26, 2021 via Android
    6
    这个是某年愚人节某个蛋疼的人搞出来的 joke😂
    luckyrayyy
    luckyrayyy
    Aug 26, 2021
    7
    我记得哪个网站返回过这个...第一次看见也震惊了,是 B 站还是哪里
    kidlj
    kidlj
    Aug 27, 2021
    8
    用 http client 爬豆瓣,不修改 user-agent 的话返回这个状态码。
    jim9606
    jim9606
    Aug 27, 2021❤️1
    9
    其实 IETF 每年愚人节都会发一些恶搞 RFC ( https://zh.wikipedia.org/wiki/%E6%83%A1%E6%90%9ERFC )
    印象深刻的还有 RFC1149 信鸽网络协议,RFC1606 IPv9 。
    IPv9 还在国内 CS 圈子炒作过一阵子。
    minmini
    minmini
    Aug 27, 2021❤️3
    10
    masterclock
    masterclock
    Aug 27, 2021
    11
    RFC8567 Customer Management DNS Resource Records
    这个似乎有类似实现,但找不到那个网站了,客户数据全部存在 DNS 记录里
    Greenm
    Greenm
    Aug 27, 2021
    12
    华为云的 WAF 拦截之后返回的请求就是 418
    misaka19000
    misaka19000
    Aug 27, 2021❤️1
    13
    @minmini 哈哈哈这个网站太好了😂
    tsingwong
    tsingwong
    Aug 27, 2021
    14
    @minmini 这个网站有点意思,收藏了
    cjh1095358798
    cjh1095358798
    Aug 28, 2021
    15
    @minmini 哈哈 太好玩儿了
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   966 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 62ms · UTC 22:19 · PVG 06:19 · LAX 14:19 · JFK 17:19
    ♥ Do have faith in what you're doing.