V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
yazoox
V2EX  ›  Neovim

我的这个 neovim init.vim 配置,怎么突然不能用了?

  •  
  •   yazoox · 92 天前 · 559 次点击
    这是一个创建于 92 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如题,原来是工作的好的,所以我备份到了 git repo 。

    现在有一台新的 mbp ,intel 的芯片,系统是 macOS Montery
    于是 brew install neovim 成功安装了 neovim
    然后我把这个 init.vim 下载拷贝到 ~/.config/nvim 下面,
    再输入 nvim ,结果,就报了一大堆错误。如图所示,

    配置文件: https://github.com/alexya/envconfig/blob/master/init.vim

    1.png 2.png

    7 条回复    2022-05-10 09:45:45 +08:00
    dekuofa
        1
    dekuofa  
       92 天前 via iPhone
    问题应该出在第三行 plug 没安装吧 这类包管理器一般需要手动安装 去 github 上看对应文档
    ynyounuo
        2
    ynyounuo  
       92 天前 via iPhone
    因为你需要 initialize vim-plug

    说实话无法通过搜索解决这种问题的话就先用那种通用的、少 breaking changes 易升级改动的 neovim/vim 配置比较好,比如什么 lunar 啊 space 啊之类的

    这种偏向于个人 dotfile 的配置建议至少较为熟练再去用
    gogorush
        3
    gogorush  
       92 天前
    先安装 plug 插件管理器
    然后通过 pluginstall 安装你这里所有的插件
    whenov
        4
    whenov  
       92 天前
    neovim 用内置的插件管理器就够了吧
    drackzy
        5
    drackzy  
       92 天前
    plug 初始化时候需要运行一次 shell 命令安装 plug ,你查查 plug 的 github repo 有说明。
    jdhao
        6
    jdhao  
       92 天前 via Android
    还是老实用 vscode ,这个错误一搜索就知道什么意思了,你不太适合用 neovim 🤪
    SjwNo1
        7
    SjwNo1  
       92 天前
    先 install 插件儿
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3163 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 33ms · UTC 10:37 · PVG 18:37 · LAX 03:37 · JFK 06:37
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.