V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
Sponsored by
LinkedIn
不坐班的神仙工作 · 去任何你想去的地方远程,赚一线城市的工资
2000 个不用出门 Social 的全球远程工作,帮助 V2EX 的小伙伴开启全新的工作方式。
Promoted by LinkedIn
JL1990
V2EX  ›  问与答

C 应用程序兼容性问题(centos5/6/7)

  •  
  •   JL1990 · 92 天前 · 518 次点击
    这是一个创建于 92 天前的主题,其中的信息可能已经有所发展或是发生改变。

    如果在 Ubuntu 上编译,请教大佬们,怎么适配到 centos 各个版本上去?目前已知问题有 glibc 不兼容(只能向下兼容,但在低版本系统上编译,较新的第三方库又不支持了)

    8 条回复    2022-06-29 22:21:19 +08:00
    hefish
        1
    hefish  
       92 天前
    编译成静态的。跟 go 那样。
    shylockhg
        2
    shylockhg  
       92 天前
    各个版本编译一份
    timpaik
        3
    timpaik  
       92 天前 via Android
    glibc 不支持静态链接,放弃旧版本吧。
    virusdefender
        4
    virusdefender  
       92 天前
    楼上正解,glibc 静态编译不是那么简单的,各种坑,某些情况下完全不能实现
    nightwitch
        5
    nightwitch  
       92 天前
    不用 glibc ,用 musl libc
    ysc3839
        6
    ysc3839  
       92 天前 via Android
    用旧版本 glibc 编译,第三方库全都自己编译,然后静态链接或者附带 so
    msg7086
        7
    msg7086  
       92 天前
    你又用新库又要支持老版本吗……
    kokutou
        8
    kokutou  
       91 天前
    7 就行了。。。5/6 还有兼容的必要吗。。。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2740 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 43ms · UTC 11:45 · PVG 19:45 · LAX 04:45 · JFK 07:45
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.