首页   注册   登录
 0x8192dd 最近的时间轴更新

0x8192dd

V2EX 第 283016 号会员,加入于 2018-01-15 18:20:54 +08:00
今日活跃度排名 25823
0x8192dd 最近回复了
21 天前
回复了 Spike2019 创建的主题 Android 现在学安卓过时吗?
怎么说呢,目前市场上原生 Android 留给新手的坑不多,市面上大部分都是平台级产品,招肯定都是招有工作经验 hold 住的,而且或多或少涉及 NDK、OpenGL、ffmpeg 这些东西,外包项目出于开发成本和跨平台的考虑用 Hybrid、RN、Flutter 的又比较多,需要你 Android、iOS 都有一定经验才 hold 住,否则遇到兼容问题你只能头破血流。

推荐 Java 后端+前端 Vue/React,自己做东西 OK,就业面也很广,等你用这套东西起步,把互联网行业的技术栈熟悉的差不多了,想做啥就随便了
98 天前
回复了 ly529 创建的主题 Android android 动画你们都是怎么做的
特别复杂的动画,公司由没有搞特效的就用序列帧呗,美术弄这种很快的,你用代码画几天又不好维护,当然能用 Lottie 还是最好的
我觉得楼主有个误区,就跟很多学编程语言的一样,觉得报个什么班或者认个师傅“带一带”,闭关修炼一段时间,就可以学成出山,阅文自如了。
说白了你看文档难在于你略浮躁,自己在不断地在心里暗示自己是看不下去的,然后就真看不下去了。
技术文档又不是小说,能有多复杂的语法结构?高中水平绝对够了,难点不在专业词汇的积累么,专业词汇就是遇到一个查一个积累下来的,没有什么捷径。
如果你一直抱有“不学到一定水平”就不想去用这种想法,你学任何语言包括编程语言都会很困难的。
IT 领域什么证的不好使,就学位证好使,这个证都不考,编什么程呢。之前 B 站那个写了 flv.js 的大神不也读书深造去了么。老老实实复读去吧
还有几条比较重要的
Android 2.x 已经绝迹,目前比较适合的最低支持版本是 4.1.2 ( API 16 ),预计在未来 1 ~ 2 年内,Android 生态圈会全面放弃支持 5.0 ( API 21 )以下的系统
Android 6、7、8、9 版本均对流氓行为做了大幅限制,未来会更严,一些老得歪门邪道基本别想再生效了,在开发新项目时必须注意权限适配
command+回车直接发出去了……
还有几条比较重要的
Android 2.x 已经绝迹,目前比较适合的最低支持版本是 4.1.2 ( API 16 ),预计在未来 1 ~ 2 年内,Android 生态圈会全面放弃支持 5.0 ( API 21 )以下的系统
Android 6、7、8、9 版本均对流氓行为做了大幅限制,未来会更严,一些老得歪门邪道基本别想再生效了,在开发新项目时必须注意权限适配
13 年那会还没有 android support library 的概念吧,现在很多重要的组件和控件都是通过 support 包提供的
AndroidStudio 已经全面替代 eclipse
RxJava + Retrofit 在 Android 项目中大幅普及,基本已成新项目标配
244 天前
回复了 sw926 创建的主题 Android 小米的开发者设计是不是 nc
oppo 开发者模式 10 分钟自动关闭还要输入验证码才能开启,都是迷一般的懒政一刀切
258 天前
回复了 sdushn 创建的主题 Android flutter or kotlin
@passerbytiny 国内对于跨平台、热更新之类加快版本迭代速度方案的迷之追求,很大一部分来源于项目管理太辣鸡,正常的原生版本迭代速度赶不上 SB 领导和产品拍脑门的速度,以及在这种拍脑门速度下造成的擦屁股频率提升
关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   953 人在线   最高记录 5043   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.3 · 12ms · UTC 22:31 · PVG 06:31 · LAX 14:31 · JFK 17:31
♥ Do have faith in what you're doing.