pb941129

pb941129

V2EX 第 206400 号会员,加入于 2016-12-17 02:22:53 +08:00
今日活跃度排名 4701
pb941129 最近回复了
@Hack3rHan 这个方法我去年就试过了,没用的。🤣
@dadachen1997 我是昨天白苹果升级正常,黑苹果无法升级...所以一开始以为你是黑苹果
@dadachen1997 那试试这个方法,无责任转载自黑苹果社区:

1. 进入恢复模式,打开终端

csrutil disable

csrutil authenticated-root disable


2.重启进系统

sudo mount -uw / && killall Finder 打开读写权限

diskutil list 找到你的系统盘

diskutil apfs listSnapshots diskXsX 查快照信息。 第一个 X 是磁盘号,第二个 X 是分区号,选你的 bigsur 系统分区 15g 左右那个。


3.删除有问题的快照

diskutil apfs deletesnapshot diskXsX -name 快照名

-uuid 快照编号

-xid 快照编号

3 个后缀任选其一,快照都删完。


4.创建新的 APFS 快照

sudo bless --folder /volume/分区名字 /System/Library/CoreServices --bootefi --create-snapshot


重启后再去 diskutil list,有快照分区的话就算完成了。
是黑苹果吧,将 Misc-Security-SecureBootModel 改成 Disabled 就解决了。
7 天前
回复了 chinvo 创建的主题 iOS 新版 Gboard 符号乱码谨慎升级
确实,而且日文全部都是乱码了。
8 天前
回复了 sprzwty 创建的主题 macOS macOS Big Sur 更新到了 beta 8
升级的时候有提示“需要完整安装器才能升级“的吗
9 天前
回复了 jreey0391 创建的主题 macOS beta7 怎么样了, beta6 你们都说不能用
@ZavierXu 还有一个 bug 用了你的 softwareupdate --all --install --force 这个命令,系统偏好设置里面的软件更新提示我有 CLT 更新,然后点了下载安装成功,再检查,又有了,无穷无尽...
9 天前
回复了 jreey0391 创建的主题 macOS beta7 怎么样了, beta6 你们都说不能用
@ZavierXu 我真的不知道正式版发布了之后,系统能不能自动把这些版本垃圾给清理了...还有一个强烈不推荐升级的理由是 Bartender 到现在都用不了
9 天前
回复了 jreey0391 创建的主题 macOS beta7 怎么样了, beta6 你们都说不能用
@ZavierXu 确实可以,我看了下,还是下载了 Command Line Tools beta 5 for Xcode 🤪 也就更证实 9.17 发布的 CLT 压根不兼容 macOS 11.0,这版本管理乱到飞起...
9 天前
回复了 jreey0391 创建的主题 macOS beta7 怎么样了, beta6 你们都说不能用
@ZavierXu 我刚刚强删了 CLT (/Library/Developer/CommandLineTools 这个文件夹),然后试图用 xcode-select --install 命令重新安装,结果直接提示“不能安装该软件,因为无法从软件更新服务器获得。“ 你可以试一下。
关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   708 人在线   最高记录 5168   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 9ms · UTC 21:13 · PVG 05:13 · LAX 14:13 · JFK 17:13
♥ Do have faith in what you're doing.