silerLee 最近的时间轴更新
silerLee

silerLee

V2EX 第 492221 号会员,加入于 2020-05-29 18:31:30 +08:00
silerLee 最近回复了
简洁又好看. 很有意思的东西
21 天前
回复了 wszgrcy 创建的主题 程序员 刷题要刷到什么程度?
能告知下有哪些公司考算法吗(bat 之外).我面的很多问的算法都很简单.leetcode easy 甚至都算不上
我歪个楼啊. 合肥现在八成首付.就是因为投资的人太多了.
23 天前
回复了 rhacker1995 创建的主题 职场话题 吐槽最近带的一个"新人"
最近陷入了自我否定.看了 lz 描述的新人.给了我一点信心
28 天前
回复了 lianglu 创建的主题 程序员 Java 有什么开源框架值得深入研究?
没人说 JDK 吗.千锤百炼的东西 最能提升内功了.我每次看 jdk 都会看看作者 ...比如 道格李
40 天前
回复了 opentrade 创建的主题 酷工作 RustDesk 招聘 Rust/C++/Golang 远程
有在使用你们的产品.真的很棒.
41 天前
回复了 AriesSky 创建的主题 酷工作 [上海][WLB] SAP 急招 Java 高级开发
能视频面吗
jndi 开发和测试都无权查看生产的配置数据. 配置文件打包的开发或者测试能看到
45 天前
回复了 fighterhit 创建的主题 Java 修 log4j 漏洞后感,请大佬解惑
第一个问题:pom 文件是继承的.这是一个优先级的问题只会取一个版本,类似于子类重写了父类的实现.优先使用你的项目的 pom 的版本指定的依赖.一定会覆盖下层第三方包依赖因为你在本地显示声明了.

第二个问题 classes 文件并不是二进制只是字节码.jar 包的加载过程是去加载器中查找依赖的包.那么你的 pom 已经定义了新的包只会使用哪个版本的包.这就是为什么安全升级有时候你发现升级的版本不兼容过新.因为这个构建是不知道版本的它只认完整的包名+类名,你不声明版本.它自带的 pom 会引入依赖.你声明了就会使用你显示声明的版本的包. 建议看下 JVM 加载 jar 的流程.

如何去验证?
你完全可以排掉依赖的包.加载的时候就会报错 notfoundclass.
59 天前
回复了 PDdavon 创建的主题 职场话题 普通人的 offer 选择,求大家指点
很多自研的公司开的还没外包高.我也很奇怪这是为什么
关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4474 人在线   最高记录 5497   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 14ms · UTC 06:28 · PVG 14:28 · LAX 22:28 · JFK 01:28
Developed with CodeLauncher
♥ Do have faith in what you're doing.