V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
EdisonLee
V2EX  ›  宽带症候群

求助。朋友家有公网 IP,我用他家网络作为 Wireguard 中继,内网 IP 已可以成功互访,但是串流游戏无画面。

  •  
  •   EdisonLee · 50 天前 · 1839 次点击
    这是一个创建于 50 天前的主题,其中的信息可能已经有所发展或是发生改变。

    用内网 IP 连接家里的 NAS 看电影一切正常,但是试了用 Chiaki 串流家中 PS5 能连接上,H265 编码画面全灰,H264 编码有画面但是花屏,看了一下流量,基本只有几 K 。 用 steam 也无法显示画面,出现失败的提示,有人遇到过这种情况码,还是我哪里设置错了。

    18 条回复    2024-04-11 00:44:15 +08:00
    EdisonLee
        1
    EdisonLee  
    OP
       50 天前
    哦,之前试了 openvpn 的方案也是一样的情况,整了好几天了。
    ANYJIAWEI
        2
    ANYJIAWEI  
       50 天前 via Android
    用 tailscale 试试
    xqzr
        3
    xqzr  
       50 天前
    MTU
    cnbatch
        4
    cnbatch  
       50 天前
    把 MTU 减小一点,多试几次就可以测出能用的最大 MTU 值
    cdlnls
        5
    cdlnls  
       50 天前
    猜猜应该是 mtu 的问题
    SuperArilo
        6
    SuperArilo  
       50 天前
    我目前也在用 WG
    尝试把 WG 接口的 MTU 调到 1412 或者 1280 试试
    ttvast
        7
    ttvast  
       50 天前
    nas 看的是带宽,串流还要看延迟。用 wg 中转,那就不是直连,延迟高到一定程度了,就没法串流了
    MYDB
        8
    MYDB  
       50 天前 via iPhone
    曾经遇到过一次,是科学插件的问题,比如 openclash 需要设置绕过来源的核心端口,同时不要用 meta 内核。仅供参考
    medivhLao
        9
    medivhLao  
       49 天前
    我是使用的 tailscale 组网,Wireguard 组网的话需要一台中央服务器,你先看看你 Wireguard 服务器的上下行带宽大小,不过我建议就是用 tailscale 或者 zeroone 等点对点组网,MTU 我觉得你没有特别设置应该都是默认的,1480 1500 ,你使用 moonlight 打开串流信息看看传输速率
    lgb1
        10
    lgb1  
       49 天前
    最近挂了 wireguard 其他服务也是正常,但是 moonlight 也是串流画面黑屏
    nailong2
        11
    nailong2  
       49 天前
    可能是不支持组播协议吧?可以先建立 GRE ,再用 wireguard 封装 GRE 隧道试试
    EdisonLee
        12
    EdisonLee  
    OP
       49 天前 via Android
    同地区,延迟 30 左右。MTU 设置到 1280 了,clash 关掉了,还是一样耶
    EdisonLee
        13
    EdisonLee  
    OP
       49 天前 via Android
    @medivhLao 朋友家 OpenWrt 自己搭的土八路,他电信 1000M/50M ,基本上跑满了,wireguard 也是点对点的,默认 MTU 是 1420 ,串流基本上是没有速率,其他都满速
    cnbatch
        14
    cnbatch  
       49 天前
    既然是串流游戏,那就假设用的是 Windows 系统。

    试下用这条命令:

    ping -l MTU 数值 -f 192.168.x.x

    其中 MTU 数值从 1500 开始逐步减少,直到能通为止
    (注意,-l 是小写 L ,不是大写 i )

    多试几次就能试出可用的最大 MTU 值
    EdisonLee
        15
    EdisonLee  
    OP
       49 天前
    @cnbatch 试到是 1252 ,但是 openwrt 无法设置 1280 以下
    jummnm
        16
    jummnm  
       49 天前
    直接在 openwrt 的 system/advancedplus 进阶参数编辑修改
    jummnm
        17
    jummnm  
       49 天前
    network 选项
    config interface 'wireguard'
    option proto 'wireguard'
    option private_key 'xxxxxxxxxxx'
    option listen_port '10667'
    list addresses '10.0.13.1/24'
    option mtu '1280'

    config wireguard_wireguard
    option description '导入对端配置'
    option public_key 'xxxxxxx'
    list allowed_ips '0.0.0.0/0'
    list allowed_ips '::/0'
    option persistent_keepalive '25'
    option endpoint_host 'xxxx.xxx'
    option endpoint_port '10667'
    EdisonLee
        18
    EdisonLee  
    OP
       49 天前 via Android
    @jummnm OpenWrt 的 woreguard 设置应该在 etc/config/network ,进去改了 MTU ,还是没用<(ToT)>
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   5391 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 03:03 · PVG 11:03 · LAX 20:03 · JFK 23:03
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.