V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
dqflyer
V2EX  ›  Android

今天升级了 Android Studio 2.0 Beta 7,项目出错,发现跟 Volley 有关……

  •  
  •   dqflyer · 2016-03-17 16:18:18 +08:00 · 5299 次点击
    这是一个创建于 2338 天前的主题,其中的信息可能已经有所发展或是发生改变。
    升级后出现这个错误:

    Gradle 'Xxxxx' project refresh failed

    Error:Cannot configure the 'publishing' extension after it has been accessed.

    初步排查是 Volley Module 的问题,更新了 volley 的最新代码,但是问题依旧,谷歌了一天都无解……求破,谢谢!
    15 条回复    2016-03-31 09:58:31 +08:00
    wanttofly
        1
    wanttofly  
       2016-03-17 16:57:50 +08:00
    关闭 vpn or 重启 studio or 重启电脑 or 重新连接宽带(或者 wifi)
    dqflyer
        2
    dqflyer  
    OP
       2016-03-17 17:18:45 +08:00
    @wanttofly 真的全试过,都不行
    honeycomb
        3
    honeycomb  
       2016-03-17 17:42:57 +08:00
    @dqflyer

    安装完会提醒更新 gradle:2.0.0-beta7
    和这个有关系吗?
    livepps
        4
    livepps  
       2016-03-17 18:02:28 +08:00
    是不是跟 bulde.gradle 中的 gradle 的版本有关,改成原来的试试。
    suliuyes
        5
    suliuyes  
       2016-03-17 18:53:28 +08:00
    我也是这个问题。正在翻江倒海的查…… 手贱啊不该升级的。严重影响进度。
    maemo
        6
    maemo  
       2016-03-17 20:08:25 +08:00
    我用的是最新的 2.1 preview3,没有遇到过啊,你再升级试试
    greenskinmonster
        7
    greenskinmonster  
       2016-03-17 20:26:23 +08:00
    这个。。。
    稳定版的开发环境要留一套啊, Android Studio 的配置文件是按版本不同目录保存的,所以稳定版和尝鲜版程序分开即可。
    dqflyer
        8
    dqflyer  
    OP
       2016-03-17 21:53:29 +08:00
    最后还是恢复了 Android Studio 的版本到 beta6 就 OK 了
    LittleMK
        9
    LittleMK  
       2016-03-18 11:43:16 +08:00
    我用的也是 volley ,没问题。
    MAC OS X 10.11.3
    AS 2.0 beta7
    Gradle 2.4.0
    Android Plugin Version 1.3.0
    thinkloki
        10
    thinkloki  
       2016-03-18 13:48:27 +08:00
    现在都有 PreView3 了,我用的是这个。
    suliuyes
        11
    suliuyes  
       2016-03-18 17:14:23 +08:00
    @thinkloki @maemo 你们都好激进啊……公司的项目我只敢选到 beta channel 。怕搞出事就玩大了。自己玩到无所谓。
    thinkloki
        12
    thinkloki  
       2016-03-18 17:42:31 +08:00
    @suliuyes 我也是自己玩的,自己电脑上装的,公司电脑还是老老实实 1.5
    maemo
        13
    maemo  
       2016-03-18 22:56:37 +08:00
    @suliuyes 其它同事还在用 eclipse 呢,就我和另一个在用,不过他们都是工作近十的了,习惯 eclipse 了
    Yasic
        14
    Yasic  
       2016-03-20 16:33:53 +08:00
    电脑上存着从 1.2 到 2.0beta6 的 Androidstudio ,之前被版本坑过,留下阴影了、、
    dqflyer
        15
    dqflyer  
    OP
       2016-03-31 09:58:31 +08:00
    这个问题在 stackoverflow ( http://stackoverflow.com/questions/36079404/errorcannot-configure-the-publishing-extension-after-it-has-been-accessed )看到解决办法:
    注释掉 volley 中 build.gradle 的 apply from: 'bintray.gradle' 这一句就行了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2650 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 15:09 · PVG 23:09 · LAX 08:09 · JFK 11:09
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.