首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Jekyll
http://jekyllrb.com/
Jekyll on GitHub
https://github.com/mojombo/jekyll
Jekyll-bootstrap
http://jekyllbootstrap.com/
Octopress
http://octopress.org/
V2EX  ›  Jekyll

Jekyll 的 markdown 解析真是蛋疼啊

  •  
  •   domty · 2016-03-31 17:02:22 +08:00 · 8050 次点击
    这是一个创建于 1349 天前的主题,其中的信息可能已经有所发展或是发生改变。

    同一篇 markdown 文档,用 sublime 的 markdown preview 插件预览效果是正常的 结果发布到 jekyll 本地看效果,文档解析的一塌糊涂

    话说有招儿吗。

    我已经从 hexo 滚回 jekyll 一次了。。。

    17 回复  |  直到 2016-04-01 19:42:03 +08:00
        1
    Livid   V2EX Moderator   2016-03-31 17:03:11 +08:00
    如果是用于文档网站的话,试试 pip install mkdocs
        2
    ChiangDi   2016-03-31 17:04:08 +08:00
    Jekyll 可以换 makdown 解析器的。
        3
    sparanoid   V2EX Moderator   2016-03-31 17:10:04 +08:00
    不知道是什么解析器, Jekyll 最近换过默认的 Markdown parser , Rouge 的效果好一些
        4
    domty   2016-03-31 17:10:41 +08:00
    @Livid
    不是网站啊, jekyll 就是一个生成静态博客的工具。
        5
    domty   2016-03-31 17:15:02 +08:00
    @ChiangDi
    还有其他的解析器吗,现在配的是 kramdown
        6
    domty   2016-03-31 17:16:09 +08:00
    @sparanoid
    我现在的 jekyll 是 3.1.2
    本地 new 新项目的配置文件里给出的 markdown parser 还是 kramdown

    rouge 怎么配?
        7
    thcode   2016-03-31 17:25:18 +08:00
    Markdown 因为没有「标准」,所以各个解释器提供的特性是不一样的,如果 kramdown 不能满足需求,试试 redcarpet 。
        8
    sparanoid   V2EX Moderator   2016-03-31 17:27:20 +08:00
    @domty 啊,记错了, Rouge 是语法高亮的, Kramdown 的确是默认的 Markdown 解析,具体遇到了什么解析问题?
        9
    domty   2016-03-31 17:40:16 +08:00
    @sparanoid

    比如
    ```JavaScript

    ```
    代码区块后面跟着 空行再跟着### 三级标题的话, jekyll 的就解析失败。 后面三级标题的###以及之后的 markdown 代码不解析直接显示出来了。

    markdown preview 预览的效果是正常的
        10
    sparanoid   V2EX Moderator   2016-03-31 17:48:56 +08:00
    我试了下并没有问题,这是我的相关配置:
        11
    domty   2016-03-31 18:06:43 +08:00
    @sparanoid
    这种问题很诡异,因为文章里相同模式的代码段有三处,但是只有这一处出现了错误。

    gist 的代码段配完之后,我要在本地部署看效果需要安装其他什么 gem 吗
        12
    wittyfox   2016-03-31 22:27:53 +08:00 via Android
    因为 Jekyll 和 Sublime 不一样,所以就是 Jekyll 坑。。。
        13
    Bardon   2016-03-31 23:25:56 +08:00
    请用 ruby2.0.0 以上的版本,安装 jekyll 3.0 以上的版本。

    然后,你本地 jekyll 的 style 配好了吗?你的 _config.yml 是啥?
    在 kramdown 下你知道要启用什么才能使用 fenced code blocks 吗?
    遇到问题为什么不去 jekyll 官网逛一遍呢?这是求学的态度?

    好吧,我正好现在有点闲,啰嗦了几句。不过也把思路给你理顺了。
        14
    jasonliao   2016-04-01 09:17:20 +08:00 via iPhone
    jekyll3.0 之后默认用 kramdown ,之前我升了之后,代码块也有很大的问题,例如在 ol 和 ul 里的代码块,但是现在也可以解决了。如果你也有这样的问题,可以找我 😎
        15
    domty   2016-04-01 10:28:54 +08:00
    @Bardon

    ruby version: 2.2.4
    jekyll versuib:3.1.2
    gem version:2.4.5.1

    然而这个 markdown 文档放到 sublime 解析正常,传到 github 上看 markdown 解析正常,传到 cmd markdown 解析依然正常,就 jekyll 解析有问题,怪我咯?

    _config.yml 里关于 markdown 的配置默认生成后我就没怎么动过
        16
    Bardon   2016-04-01 19:41:04 +08:00
    @domty fenced code block 本地 jekyll 默认不启用
    为什么不查官方文档?那怕过去了 24 小时
    https://jekyllrb.com/docs/configuration/

    你需要
        17
    Bardon   2016-04-01 19:42:03 +08:00
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2622 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 14:04 · PVG 22:04 · LAX 06:04 · JFK 09:04
    ♥ Do have faith in what you're doing.