V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
uxstone
V2EX  ›  Node.js

node_modules 能不能做成 java 的 jar 包那种形式?

  •  
  •   uxstone · 2016-08-04 15:34:50 +08:00 · 4219 次点击
    这是一个创建于 2119 天前的主题,其中的信息可能已经有所发展或是发生改变。

    目录层次太深了!

    node 官方没注意到这个问题吗?

    16 条回复    2016-08-16 13:15:19 +08:00
    zonghua
        1
    zonghua  
       2016-08-04 15:43:57 +08:00 via iPhone
    是不是目录太深,文件太多导致在 windows 的资源管理器无法复制移动?确实可怕,一个工程往往有几万个文件
    mota
        2
    mota  
       2016-08-04 15:48:21 +08:00
    npm3 扁平化了,层次不深了,文件夹多了
    my101du
        3
    my101du  
       2016-08-04 15:51:43 +08:00
    同感,有时候打包发给同事。如果忘了 tar --exclude=node_modules 的话,速度感人…… ;另外有时候用 ftp 上传目录,忘了排除的话,也会导致软件假死……
    不知道在完成后弄成一个包是有什么技术困难还是?
    uxstone
        4
    uxstone  
    OP
       2016-08-04 16:13:30 +08:00
    @zonghua @mota @my101du
    ES6 说目标是使 js 称为企业级开发语言,如果这个问题不能很好解决,会很麻烦的
    就算不做成 jar 包的那种形式,类似 maven 的中央仓库管理也是可行的啊,一个 pom 文件就搞定
    为啥要每个 node_modules 中还有好多个 node_modules.
    又杂又乱,调试测试时 头大 .....
    srlp
        5
    srlp  
       2016-08-04 16:27:21 +08:00 via iPhone
    原始设计好像是为了多版本依赖共存。现在最新的应该拍扁了。
    hxtheone
        6
    hxtheone  
       2016-08-04 18:18:44 +08:00
    LZ 赶紧升级到 npm3, npm3 安装的依赖就是在同一层目录下, 早就没有一层套一层的 node_modules 了
    mota
        7
    mota  
       2016-08-04 18:36:27 +08:00
    @uxstone npm3 不是这种层级的了,是扁平化的了
    yzhen123
        8
    yzhen123  
       2016-08-04 20:34:04 +08:00 via Android
    @uxstone npm 不就相当于 maven ?
    murmur
        9
    murmur  
       2016-08-04 20:52:52 +08:00
    @uxstone 不是有项目的配置么 删除了之后 npm install 就全装回来了
    kimown
        10
    kimown  
       2016-08-04 21:25:10 +08:00
    https://docs.npmjs.com/how-npm-works/npm3 这是 npm3 下载依赖的结构图
    jybox
        11
    jybox  
       2016-08-04 21:37:48 +08:00
    Septembers
        12
    Septembers  
       2016-08-04 22:09:59 +08:00   ❤️ 1
    rayshen
        13
    rayshen  
       2016-08-05 19:36:32 +08:00
    为什么 nodejs 的节点这 CSS 这么白??有什么渊源吗
    yinfxs
        14
    yinfxs  
       2016-08-07 14:02:59 +08:00
    @Septembers npm pack 是正解
    wangxiaoer
        15
    wangxiaoer  
       2016-08-11 17:05:38 +08:00
    @kimown : 看了下图,感觉特么的不彻底啊,还是存在安装在某个依赖下面的依赖,假设图中的 B2.0 如果依赖另外一个第一层的依赖会怎么办。

    很奇怪为毛不搞成跟 maven 一样,库名--版本号--文件的方式呢
    serial
        16
    serial  
       2016-08-16 13:15:19 +08:00
    不会写 package.json ? 别人的包怎么依赖跟你是无关的。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1076 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 28ms · UTC 20:51 · PVG 04:51 · LAX 13:51 · JFK 16:51
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.