首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  macOS

如何使不符合 legacy 的 add-on,可用于 Firefox 57?

  •  
  •   endosome · 257 天前 · 1340 次点击
    这是一个创建于 257 天前的主题,其中的信息可能已经有所发展或是发生改变。
    在 about:config 里面设置,并不能奏效。
    请问除了降级之外,有没有办法让旧 add-on 可以兼容于 Firefox 57 ?
    9 回复  |  直到 2017-11-05 10:36:01 +08:00
        1
    lhx2008   257 天前 via Android
    在 chrome 里面的插件让火狐签名,曲线救国
        2
    endosome   257 天前
    @lhx2008 怎么操作?
        3
    pynix   257 天前 via iPhone
    应该没法使用了,旧的 API 已经移除了
        4
    endosome   257 天前
    Chrome Store Foxified ?
        5
    lhx2008   257 天前 via Android   ♥ 1
    @endosome 下载 crx,改后缀成 xpi (其实只是压缩包),然后在火狐插件网站点提交插件,然后选择不公开,然后就可以帮你检查兼容性并且秒获得一个签名,然后就可以装在任意火狐浏览器上面了。但是肯定会有各种 bug,不过凑合能用。最好的方法还是等作者自己支持 57
        6
    xuan880   257 天前 via Android
    config 里面有个参数可以让 57 兼容旧版扩展。你上网查查看。
        7
    marenight   257 天前 via iPhone
    IMPORTANT: if you're using Firefox 57 you'll need to open about:config and turn the extensions.legacy.enabled preference to true, otherwise the browser will refuse to install Noscript.
        8
    yingfengi   257 天前 via Android
    找一找替代品吧
        9
    chyiz   257 天前
    Developer Edition 和 Nightly 里 extensions.legacy.enabled 还是有效的。但是很多很早就 deprecated 的 API 都已经移除了。所以能装也不一定能用。
    LZ 啥扩展?也许已经有替代品了。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   实用小工具   ·   1814 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 17ms · UTC 14:11 · PVG 22:11 · LAX 07:11 · JFK 10:11
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1