V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python Sites
PyPI - Python Package Index
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
Vkin
V2EX  ›  Python

pip3 install apscheduler 报错,应该如何解决?

  •  
  •   Vkin · 2017-11-09 18:22:55 +08:00 · 3289 次点击
    这是一个创建于 1690 天前的主题,其中的信息可能已经有所发展或是发生改变。

    pip3 install apscheduler

    Collecting apscheduler

    Could not fetch URL https://pypi.python.org/simple/apscheduler/: There was a problem confirming the ssl certificate: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:748) - skipping

    Could not find a version that satisfies the requirement apscheduler (from versions: )

    No matching distribution found for apscheduler

    有网友提出的解决方法是 pip3 install certifi

    但似乎并没有用,因为已经安装了 certifi

    pip3 install certifi

    Requirement already satisfied: certifi in /usr/local/lib/python3.6/site-packages

    Python 版本 3.6,macos10.12

    6 条回复    2017-11-09 21:35:21 +08:00
    TimePPT
        1
    TimePPT  
       2017-11-09 18:46:04 +08:00   ❤️ 1
    试试升级下 pip
    rebeccaMyKid
        2
    rebeccaMyKid  
       2017-11-09 18:51:06 +08:00   ❤️ 1
    你试下换个源. `pip3 install apscheduler -i https://pypi.douban.com/`
    Vkin
        3
    Vkin  
    OP
       2017-11-09 19:50:12 +08:00
    @TimePPT 无法升级,升级也是同样的提示:Could not fetch URL https://pypi.python.org/simple/pip/: There was a problem confirming the ssl certificate: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:748) - skipping
    Vkin
        4
    Vkin  
    OP
       2017-11-09 19:51:06 +08:00
    @rebeccaMyKid 也是同样的提示:
    pip3 install apscheduler -i https://pypi.douban.com/

    Collecting apscheduler
    Could not fetch URL https://pypi.douban.com/apscheduler/: There was a problem confirming the ssl certificate: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:748) - skipping
    Could not find a version that satisfies the requirement apscheduler (from versions: )
    No matching distribution found for apscheduler
    raysonx
        5
    raysonx  
       2017-11-09 19:53:59 +08:00 via Android   ❤️ 1
    用 curl 访问一下试试。
    猜测你机器的 ca 证书有问题。
    Vkin
        6
    Vkin  
    OP
       2017-11-09 21:35:21 +08:00
    @raysonx 的确是证书的问题。谢谢🙏
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1233 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 23ms · UTC 18:13 · PVG 02:13 · LAX 11:13 · JFK 14:13
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.