V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Zach369
V2EX  ›  Java

Java sdk 选择

  •  
  •   Zach369 · 2019-07-26 14:54:14 +08:00 · 5144 次点击
    这是一个创建于 1225 天前的主题,其中的信息可能已经有所发展或是发生改变。

    好久没写 java 了,看下了官网,目前已经更新到 sdk12 了,大家目前开发 都是使用哪个版本那。1.8 sdk 和 1.11 都是 LTS。 怎么选择那?

    27 条回复
    pexcn
        1
    pexcn  
       2019-07-26 14:57:37 +08:00
    我用了 JDK 11
    Zach369
        2
    Zach369  
    OP
       2019-07-26 14:59:24 +08:00
    @pexcn 线上环境使用?
    Cbdy
        3
    Cbdy  
       2019-07-26 15:09:14 +08:00
    我司用这个
    Lonely
        4
    Lonely  
       2019-07-26 15:09:31 +08:00
    线上没有强制要求的话就选 11,自己玩的话就选最新的
    Cbdy
        5
    Cbdy  
       2019-07-26 15:09:33 +08:00
    qwerthhusn
        6
    qwerthhusn  
       2019-07-26 15:14:09 +08:00
    avalon0624
        7
    avalon0624  
       2019-07-26 15:23:06 +08:00
    jdk 8
    pexcn
        8
    pexcn  
       2019-07-26 15:26:00 +08:00
    @Zach369 当然是自己玩,线上还是用 JDK 8
    LosLord
        9
    LosLord  
       2019-07-26 15:29:05 +08:00
    现在选 JDK 要看是不是 LTS 版本,8、11 是 LTS 版本,从这两个里面选。

    题外话:话说真搞不懂一出新版本,一帮在那说 Java 更新快学不动的人,距离下次 LTS 版本还早得很,时间还不够?怀疑是个假 javaer
    LosLord
        10
    LosLord  
       2019-07-26 15:32:54 +08:00
    @LosLord Docker 这种的话,可以选择新版本,反正一个应用一个 JDK。如果用到有些使用 Unsafe API 第三方库( netty 这种),就使用 Java8。JDK8 不在意授权问题能选择就选择 Oracle JDK,JDK11 选 adoptopenjdk 就行,oracle 打包的那个 openjdk11 好像一直没更新。
    janxin
        11
    janxin  
       2019-07-26 15:34:50 +08:00
    别问,问就选 11
    YzSama
        12
    YzSama  
       2019-07-26 15:44:52 +08:00
    11 比 8 的体积大了好多倍。。

    目前线上还是 8
    lihongjie0209
        13
    lihongjie0209  
       2019-07-26 15:49:33 +08:00
    8
    allanzhuo
        14
    allanzhuo  
       2019-07-26 15:51:23 +08:00
    线上的话,肯定还是 8
    qiyuey
        15
    qiyuey  
       2019-07-26 15:53:46 +08:00
    线上 8,自己用 12
    519718366
        16
    519718366  
       2019-07-26 16:19:37 +08:00
    8
    guyeu
        17
    guyeu  
       2019-07-26 17:42:53 +08:00
    只有我们是 10 吗。。。
    passerbytiny
        18
    passerbytiny  
       2019-07-26 17:43:14 +08:00
    线上必须是 8,线下稳定长期用建议是 8。没有任何实际项目部署需要的话,直接最新版。
    8 肯定不能长用,早晚都要升级,但是替代它的,基本不可能是被现行版本发布策略下的任何版本,即使是那个 LTS (伪)的 11。
    Torpedo
        19
    Torpedo  
       2019-07-26 18:28:57 +08:00
    @guyeu 不懂 java,为啥要么 8 要么 11 的
    cweijan
        20
    cweijan  
       2019-07-26 18:34:53 +08:00
    还是 8 就好了, 8 之后的版本没有特别亮点的功能, 不值得升级
    zartouch
        21
    zartouch  
       2019-07-26 23:58:49 +08:00
    jdk 8 2019.1 已经停止免费维护了, 公司要求第四季度之前全部迁移到 11。 目前我们新系统已经是 11 了,主要是 zgc 对低延迟应用提升比较大

    如果是自己写点小项目,肯定用最新的 ( 12 )。公司请按照公司的支持情况来定
    anyele
        22
    anyele  
       2019-07-27 02:14:09 +08:00
    11
    jiqing
        23
    jiqing  
       2019-07-27 09:39:24 +08:00
    就是 jdk 呗,java sdk 的称呼还是挺新鲜的。
    zulu 家的 openjdk 随便用了,ssm 一把梭也不会在意细节
    guyeu
        24
    guyeu  
       2019-07-27 14:37:59 +08:00
    @Torpedo #19 8 和 11 是目前的两个长期支持版,9、10、12 发布几个月后就会停止维护。
    EastLord
        25
    EastLord  
       2019-07-27 17:51:55 +08:00
    8
    Cbdy
        26
    Cbdy  
       2019-07-27 20:41:09 +08:00 via Android
    @cweijan zgc 了解一下,性能大幅优化了解一下
    charlie21
        27
    charlie21  
       2019-07-28 12:43:23 +08:00
    对标 主流类库的稳定版本 所支持的 java 版本,没错
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1167 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 51ms · UTC 20:11 · PVG 04:11 · LAX 12:11 · JFK 15:11
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.