V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
foxyier
V2EX  ›  Elasticsearch

[求助帖]es2.X 版本升级到 7.X 请问有没有什么办法能够平滑升级.

  •  
  •   foxyier · 2020-01-13 17:42:40 +08:00 · 2004 次点击
    这是一个创建于 694 天前的主题,其中的信息可能已经有所发展或是发生改变。

    RT, 目前业务层用的 es 为 2.X 版本, 想更新到最新的 7.X 版本, 主要是 type 问题(目前数据都是一个索引对应多个类型), mapping 不兼容问题(string,text)以及数据同步问题, 想请教一下有什么良好的解决办法.

    5 条回复    2020-01-14 11:02:14 +08:00
    pmispig
        1
    pmispig  
       2020-01-13 17:55:23 +08:00
    新版本跑起来
    数据双写新老版本
    老的数据导入新的
    foxyier
        2
    foxyier  
    OP
       2020-01-13 18:26:39 +08:00
    @pmispig 多谢, 您给出的是数据同步问题的解决思路, 请问另外两种问题有没有推荐的方法呢
    wangyzj
        3
    wangyzj  
       2020-01-13 18:29:30 +08:00
    一点点升起来
    smartbot
        4
    smartbot  
       2020-01-14 00:55:57 +08:00 via Android
    官方文档有提及,好像先升级到 6.x,再升级到 7.x
    cco
        5
    cco  
       2020-01-14 11:02:14 +08:00
    不能直接到 7.x 吧。。到 6 还行,毕竟 index_type 都没得了。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2744 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 18ms · UTC 12:52 · PVG 20:52 · LAX 04:52 · JFK 07:52
    ♥ Do have faith in what you're doing.