首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
OPPO Watch
waiaan
V2EX  ›  程序员

有什么 ie8 能用的 UI 框架吗?

  •  
  •   waiaan · 53 天前 via Android · 3068 次点击
    这是一个创建于 53 天前的主题,其中的信息可能已经有所发展或是发生改变。
    没办法的需求。
    47 条回复    2020-04-08 11:59:13 +08:00
    star7th
        1
    star7th   53 天前
    bootstrap 的旧版?
    InternetExplorer
        2
    InternetExplorer   53 天前
    antd 1.x
    cuzfinal
        3
    cuzfinal   53 天前
    lulu ui
    Kylin30
        4
    Kylin30   53 天前
    pintuer ?
    580a388da131
        5
    580a388da131   53 天前
    creanme
        6
    creanme   53 天前
    layui
    des
        7
    des   53 天前
    avalon
    Terry05
        8
    Terry05   53 天前
    bootstrap 2.x
    Foxkeh
        9
    Foxkeh   53 天前   ❤️ 4
    客户不多的话,给他们装个 Chrome 然后桌面快捷方式图表和名字换成 ie8
    CismonX
        10
    CismonX   53 天前 via iPhone
    @Foxkeh 然后客户发现没法安装 ActiveX 插件🐶
    wwwap
        11
    wwwap   53 天前
    san
    TimPeake
        12
    TimPeake   53 天前
    该跑路了
    loading
        13
    loading   53 天前 via Android
    extjs
    libasten
        14
    libasten   53 天前
    @Foxkeh 人才!
    zhengfuchao2008
        15
    zhengfuchao2008   53 天前
    bootstrap 2.x 正解,还能提供一个移动端兼容方案,防止甲方提出其他无理要求
    g00001
        16
    g00001   53 天前   ❤️ 1
    可以做个客户端套个 miniblink( 迷你版 Chromium 49 ),
    用 aardio + miniblink 生成一个软件只要几句代码 - 软件体积也很小,
    支持 XP 、WIN7 、WIN10, 也支持 vue + element, react + antd 3.x 这些。
    815979670
        18
    815979670   53 天前 via Android
    @creanme #6 layui 已经不支持 ie8 了 起码大部分组件是的
    hmxxmh
        19
    hmxxmh   53 天前
    其实有点奇怪为什么还有人用 ie 浏览器啊,有人可以解答一下吗
    cnit
        20
    cnit   53 天前
    内网项目 政府银行学校呗,一个是一部分老同志学电脑上的东西慢还不愿意接受新的东西,一个是不允许随便安装软件。所以就一直用 IE 咯
    xcstream
        21
    xcstream   53 天前
    bootstrap 旧版
    w292614191
        22
    w292614191   52 天前
    miniui,支持 IE6
    Mutoo
        23
    Mutoo   52 天前
    ie 啊,专门做一个降级版,然后用 geo-bootstrap 就好了。
    https://github.com/divshot/geo-bootstrap
    mywaiting
        24
    mywaiting   52 天前
    Electron 将自己的 WebApp 打包成 exe 交货?
    snowydec
        25
    snowydec   52 天前
    easyui ?
    vindac
        26
    vindac   52 天前
    @hmxxmh 其实主要不是因为 IE8,是因为 xp 和 360 浏览器。
    很多都是 360 兼容模式,用的就是 IE8 或者 9 的内核
    luruitao
        27
    luruitao   52 天前
    bootstrap + jquery 一把梭
    zzzmh
        28
    zzzmh   52 天前
    讲道理,自己写 css,效果最好,就 ie 这性能,外加能想象到的老爷电脑。稍微内容多点估计就卡了。
    openbsd
        29
    openbsd   52 天前
    @hmxxmh #19
    ActiveX
    wanguorui123
        30
    wanguorui123   52 天前
    ext
    wanguorui123
        31
    wanguorui123   52 天前
    jqueryUI
    liuxey
        32
    liuxey   52 天前
    老套件:jQuery + easyui,当然这是后台管理系统,如果是展示类型的网页,就 jQuery + bootstrap
    ddup
        33
    ddup   52 天前
    avalon
    ansenJ
        34
    ansenJ   52 天前
    san +1 支持 IE6 呢
    lbfeng
        35
    lbfeng   52 天前
    @des
    @ddup

    作者去世了,还有人支持么
    waiaan
        36
    waiaan   52 天前
    @liuxey easyui 新版不支持 ie8 了。
    xianxiaobo
        37
    xianxiaobo   52 天前
    bootstrap3+jquery
    liuxey
        38
    liuxey   52 天前
    @waiaan #36 用 1.3.x 就行了
    tanranran
        39
    tanranran   52 天前
    layui
    tanranran
        40
    tanranran   52 天前
    @tanranran #39 至今依旧在维护更新
    memedahui
        41
    memedahui   52 天前
    extjs +1
    ddup
        42
    ddup   52 天前
    @lbfeng #35 哎。。。以前用过这个 MVVM 框架还是很稳的,兼容到 IE6,做要兼容到 IE6 ~ 8 的复杂应用,avalon 还是值得考虑。
    memedahui
        43
    memedahui   52 天前
    再送你一个 ligerui
    crist
        45
    crist   52 天前
    该跑路了
    moyupoi
        46
    moyupoi   52 天前 via iPhone
    @Foxkeh 秀,是你吗,秀
    gowk
        47
    gowk   52 天前 via Android
    mithrill 或许可以
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1075 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 21:30 · PVG 05:30 · LAX 14:30 · JFK 17:30
    ♥ Do have faith in what you're doing.