V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
tctc4869
V2EX  ›  Android

android studio 新建安卓项目,最小 api 等级,现在你们都选多少?

  •  1
     
  •   tctc4869 · 2020-07-10 09:22:17 +08:00 · 4830 次点击
    这是一个创建于 938 天前的主题,其中的信息可能已经有所发展或是发生改变。

    使用 android studio 开发 android 项目,新建一个项目,有一个 Mixnum API Level 下拉选项,猜测是安卓开发的最小 sdk 版本。

    各位建议是选哪个?我凭感觉,应该选 7.0

    36 条回复    2020-07-30 00:01:06 +08:00
    Lin0936
        1
    Lin0936  
       2020-07-10 09:24:23 +08:00
    去年是 5.0,今年刚提到 6.0
    mmrx
        2
    mmrx  
       2020-07-10 09:25:27 +08:00
    根据你产品的定位来选,选用户群体中大多数人用的版本-1 或者-2

    现在二三四线城市 Android 5.0 还有非常多
    dullwit
        3
    dullwit  
       2020-07-10 09:27:40 +08:00
    目前最低 4.0
    NewTab12138
        4
    NewTab12138  
       2020-07-10 09:33:44 +08:00
    微信最低 5.0,参考微信就可以了
    tctc4869
        5
    tctc4869  
    OP
       2020-07-10 09:33:59 +08:00
    @mmrx 5.0 的话
    @Lin0936
    GridLayout 的布局,设定的列数量,不会平均分配占满屏幕,这个只能过 java 计算解决么?
    tctc4869
        6
    tctc4869  
    OP
       2020-07-10 09:36:03 +08:00
    @tctc4869 说错了
    5.0 的话, Reply 5
    tctc4869 1 分钟前
    @mmrx 5.0 的话
    @Lin0936
    GridLayout 的布局,设定的列数量,不会平均分配占满一行,这个只能过 java 计算解决么?
    Yyyye
        7
    Yyyye  
       2020-07-10 09:38:21 +08:00
    还是看你用户群的,5.0 就可以了
    mmrx
        8
    mmrx  
       2020-07-10 09:39:25 +08:00
    @tctc4869 你要考虑两个问题

    1. 选择了高版本对用户群体有什么要求,会不会丢失大量目标用户

    2. 选择了低版本对开发和功能实现是不是有更高的成本,会不会导致你产品做不下去

    问题 1 > 问题 2 就从产品角度选
    问题 2 > 问题 1 就从技术角度选

    我是感觉技术问题想想办法总能解决
    Lin0936
        9
    Lin0936  
       2020-07-10 09:40:23 +08:00
    @tctc4869 这东西我们后来改成 RecyclerView 实现了,效果没什么差别还更灵活。
    hhecoder
        10
    hhecoder  
       2020-07-10 09:40:52 +08:00
    自己项目 7.0+,公司项目 5.0+。
    leelion6
        11
    leelion6  
       2020-07-10 09:44:20 +08:00
    公司项目是 17
    cgpiao
        12
    cgpiao  
       2020-07-10 09:57:35 +08:00
    7.0
    tctc4869
        13
    tctc4869  
    OP
       2020-07-10 09:59:33 +08:00
    @Lin0936 不是的,我不是要动态加载一个 java 列表对象,我是要写死一些东西到界面上,采取网格形式,直接写子元素的 xml,根据设定的最大列数量。平均分配子元素的 width 。类似支付宝或微信界面的一些网格上的按钮
    secretman
        14
    secretman  
       2020-07-10 10:03:32 +08:00
    @tctc4869 约束布局不香?约束布局可以设置百分比。
    LinearLayout 也可以啊,weight 分配。
    iFlicker
        15
    iFlicker  
       2020-07-10 10:11:00 +08:00
    https://developer.android.com/about/versions/android-4.4
    看一下官网文档当前最低是 19 了,公司项目大胆点就 API21,用户量大谨慎点就 API19 。
    个人看心情了(如果是我就 API23 起步)
    Lin0936
        16
    Lin0936  
       2020-07-10 10:12:24 +08:00
    @tctc4869 写死的就更没必要啦,我觉得既然有问题就换种方式实现挺好的😂
    tctc4869
        17
    tctc4869  
    OP
       2020-07-10 10:18:05 +08:00
    @Lin0936 如果不是动态加载 ui 内容的话,我不希望 java 代码里过多沾染上界面的东西。

    就算是真要动态加载 ui,我也在 Activity 里或 fragment 里屏蔽过多的控件类名的代码的存在。
    tctc4869
        18
    tctc4869  
    OP
       2020-07-10 10:20:04 +08:00
    @Lin0936 不过,你知道 android 有没有“数据驱动 ui”的 android 表单生成框架?

    在界面上只需写一个布局容器,然后获取布局容器 id,然后使用框架根据这个布局容器根据开发者的 java 代码配置生成表单
    raptor
        19
    raptor  
       2020-07-10 10:31:32 +08:00
    4.4 或 5.0 吧……毕竟我还有 5.0 的设备……
    ssynhtn
        20
    ssynhtn  
       2020-07-10 10:33:09 +08:00
    6.0 很仁慈了,我都想上 7.0
    没有千万量级用户的 app 没必要支持 5.0
    支持 4.x 除了 app 类型特殊否则就是享受自虐
    katana97
        21
    katana97  
       2020-07-10 10:39:52 +08:00
    4.0,不过只是这么写,实际上 6.0 以下的出问题都不管
    wujieyuan
        22
    wujieyuan  
       2020-07-10 10:50:00 +08:00
    我做自动售货机 app, 那些工控万年不升级, 还得支持 4.2 的系统, 非常蛋疼
    Xusually
        23
    Xusually  
       2020-07-10 10:53:25 +08:00
    一般的项目,就参考微信吧,目前是 5.0
    自己玩的项目,怎么方便怎么来,我自己的小工具都用的 API 24 ( 7.0 )
    jstony
        24
    jstony  
       2020-07-10 11:37:50 +08:00
    我们的 4.4,后台来看,4.4 的设备还是很多的
    bkmi
        25
    bkmi  
       2020-07-10 11:44:26 +08:00
    GridLayout 请使用 androidx.gridlayout.widget.GridLayout

    数据驱动 UI,可以考虑 DataBinding 、RecyclerView + DiffUtil / androidx.recyclerview.widget.ListAdapter

    或者 Flutter 、React 可能更合你口味
    classyk
        26
    classyk  
       2020-07-10 11:49:40 +08:00
    19
    hantsy
        27
    hantsy  
       2020-07-10 11:52:14 +08:00
    8.0 起步吧。

    再老的机器官方已经停止维护了。
    xiangyuecn
        28
    xiangyuecn  
       2020-07-10 11:52:56 +08:00
    大众的应用还是看图说话:



    tctc4869
        29
    tctc4869  
    OP
       2020-07-10 13:06:38 +08:00
    @bkmi DataBinding 这个对 android studio 版本有要求的把,我用的是 3.4,但目前不想用 3.5 以后的版本
    canyie
        30
    canyie  
       2020-07-10 16:31:44 +08:00
    2.3 (手动滑稽)
    winterbells
        31
    winterbells  
       2020-07-10 16:55:02 +08:00 via Android
    当然是 21 起啊

    算一下 5.0 都多少年前的了
    reactna1ve
        32
    reactna1ve  
       2020-07-10 17:36:25 +08:00
    公司项目现在还是 16
    chenjiajia9411
        33
    chenjiajia9411  
       2020-07-10 18:25:22 +08:00
    政府项目,只能 16.
    AppCompat 做的我想死。
    mgrddsj
        34
    mgrddsj  
       2020-07-11 00:22:09 +08:00 via Android
    刚刚充话费,发现联通的手机营业厅刚刚把最低 API 改为了 Android 5.0
    https://imgchr.com/i/UMIIxK
    zhugefubin
        35
    zhugefubin  
       2020-07-11 16:08:24 +08:00
    4.4 以上问题不大
    orangel
        36
    orangel  
       2020-07-30 00:01:06 +08:00
    4.4
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   实用小工具   ·   2053 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 55ms · UTC 04:56 · PVG 12:56 · LAX 20:56 · JFK 23:56
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.