V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
lancolor9812
V2EX  ›  NAS

群 晖 bitwarden 搭建成功后不能 HTTPS 访问是怎么回事呀?

  •  
  •   lancolor9812 · 292 天前 · 4439 次点击
    这是一个创建于 292 天前的主题,其中的信息可能已经有所发展或是发生改变。

    用群晖搭了个 bitwarden,证书 反代 端口转发都弄好了,通过 HTTP 可以正常用域名访问,但是用 HTTPS 的时候就不行了,证书用阿里和腾讯的免费证书都试过了也不行,这个是怎么回事呢?而且好像本地用 IP+端口用 HTTPS 访问好像也不行 这个是怎么操作呢?

    42 条回复    2020-12-17 07:21:54 +08:00
    stille
        1
    stille   292 天前 via iPhone
    不确定你反代是否正确,你可以参考这篇最后的反代和端口映射或者内网穿透的方案

    https://www.ioiox.com/archives/70.html
    ik
        2
    ik   292 天前 via iPhone
    盲猜 家宽?
    ik
        3
    ik   292 天前 via iPhone
    不对 似乎不是家宽的问题… 溜了
    dingdangnao
        4
    dingdangnao   292 天前 via iPhone
    证书有没有设为默认证书?好像有这个设置
    lancolor9812
        5
    lancolor9812   292 天前
    @stille 有一次我就是照着这个来的 我家里是公网 IP 应该不用内网穿透吧?
    des
        6
    des   292 天前 via iPhone
    先确认你的 https 访问的端口是开放的
    要不就在反代的机器上反代到 http
    hymzhek
        7
    hymzhek   292 天前
    端口通不通, 报什么错贴出来
    lancolor9812
        8
    lancolor9812   292 天前
    @hymzhek 我用工具扫我公网 IP 的 443 端口 是关闭的
    lancolor9812
        9
    lancolor9812   292 天前
    @hymzhek 没什么报错呀 就是能 HTTP 访问 HTTPS 就不能访问呀!!!有错误就是这个吧:ERR_CONNECTION_REFUSED
    precure
        10
    precure   292 天前
    https 的端口 443 开放了吗??
    lancolor9812
        11
    lancolor9812   292 天前
    @precure 公网 IP 的 443 端口不是都关着的嘛?这个需要咋弄呢?
    masker
        12
    masker   292 天前 via Android
    描述的不清不楚,很难得到好的解决方案啊。
    opengps
        13
    opengps   292 天前 via Android
    先用 443 端口,验证下普通 tcp 服务是否通畅,然后再把站点绑定证书验证一把
    lancolor9812
        14
    lancolor9812   292 天前
    @opengps 它现在是可以正常的 HTTP 域名访问呀,就是不能 HTTPS 访问。
    yyss8
        15
    yyss8   292 天前 via iPhone
    浏览器 https 默认走 443 端口 你公网 443 没开放自然连接不上
    你真想试试证书由内有效 试试用 curl 走 https 然后强行改端口到 80
    opengps
        16
    opengps   292 天前
    @lancolor9812 http 的默认端口是 tcp80,https 的默认端口是 tcp443,我的意思跟其他楼层一样,让你检查下 443 端口的通畅性
    lancolor9812
        17
    lancolor9812   292 天前
    @opengps 这个我用站长扫过我公网 IP 的端口 880 和 443 端口都是关闭状态! 不过电信的公网 IP 不是都关着的嘛?
    fatelight
        18
    fatelight   292 天前
    贴一下设置看看吧,又不知道你咋操作的
    opengps
        19
    opengps   292 天前
    @lancolor9812 端口要通,需要多个前置条件:
    1,有公网 ip
    2,公网 ip 到你的服务器之间,中间网络设备要进行端口转发
    3,你的主机里的防火墙软件要放行端口
    4,你的主机上要有应用程序监听了对外网卡的目标端口
    lancolor9812
        20
    lancolor9812   292 天前
    @fatelight https://www.ioiox.com/archives/70.html 就是跟这个教程一步一步来的 没改过 连端口都设置一样的了!!!
    lancolor9812
        21
    lancolor9812   292 天前
    @opengps 好吧 我这个公网 IP 是上周刚申请的,域名能正常 HTTP 访问 其它 2 个感觉我不太懂的样子 哎 先慢慢研究吧 谢了老哥!!!
    eijimitsuki
        22
    eijimitsuki   292 天前
    你先搭个其他的,看看 https 正常不,然后再搭 bitwarden
    eijimitsuki
        23
    eijimitsuki   292 天前
    群晖是能用的,我正用着。
    lancolor9812
        24
    lancolor9812   292 天前
    @eijimitsuki 搭什么还需要用到 HTTPS 呢?
    eijimitsuki
        25
    eijimitsuki   292 天前
    @lancolor9812 所有的远程都弄成 https 啊
    lancolor9812
        26
    lancolor9812   292 天前
    @eijimitsuki 哎 弄了半天不行去买 1PASSWORD 算了
    gaopu
        27
    gaopu   292 天前
    lastpass 免费的呀,我用几年了。
    lancolor9812
        28
    lancolor9812   292 天前
    @gaopu lastpass 取消中文这个很麻烦呀!!!
    getadoggie
        29
    getadoggie   292 天前 via iPhone
    应该是反代配置不对,我就是 docker 自建的 bitwarden,用的非标端口+Lets Encrypt 的免费证书
    lancolor9812
        30
    lancolor9812   292 天前
    @getadoggie 反代那里没有其它的吧 应该是不会错的呀 我找了好多个教程呀 不会所有反代那都错了吧 所以才觉得奇怪的呀!!!
    WebKit
        31
    WebKit   292 天前 via Android
    前几天刚装的。你在群晖自带的到代理配置一下域名跟证书就行。
    fatelight
        32
    fatelight   292 天前
    @lancolor9812 那个镜像老了,用 rs 那个,最简单
    https://registry.hub.docker.com/r/bitwardenrs/server/ 这个镜像

    反代 就 http localhost +端口 到其他 https 端口就行了,
    ferock
        33
    ferock   292 天前 via iPhone
    从来不用 443,家庭宽带别想了
    xpect
        34
    xpect   292 天前
    我也是在群晖上架的 Bitwarden,443 端口被封了。但可以用其它端口走 https,例如我的连接形式是: https://aa.xxxxx.com:61/,我用的是群晖的 Docker 来部署 Bitwarden,端口映射有几道:
    1. 在 Dockers 里,将本地端口 71 映射到了 Bitwarden 的容器端口 80 。
    2. 在 NAS 的控制面板->应用程序门户->反向代理服务器,新建了一条 https://*:61 到 http://localhost:71
    3. 在 NAS 的控制面板->安全性->证书的配置里,将 61 端口选上相应的证书
    4. 我开了 NAS 的防火墙,所以在 NAS 防火墙规则里要设置开通 61 端口
    5. 我的 NAS 是接在家里路由器后面的,所以还需要在路由器里加一条端口映射到 NAS 的 61 端口
    mooyo
        35
    mooyo   292 天前
    家宽哪来的 80 和 443 。。
    SenLief
        36
    SenLief   292 天前 via Android
    楼主你的公网 443 是关的肯定访问不到啊。你需要在路由器端口转发把内网的 443 端口转发到外网的任意端口,然后用 ip:端口的方式。
    不过你的 nginx 应该是在群晖上的,所以你路由器要转发群晖 ip 的 443 端口。
    lancolor9812
        37
    lancolor9812   292 天前
    @xpect 我也是跟你一样的呀,我是 9876 映射到 80 端口,再反代设置 9999 映射到 9876 端口。证书都是给的 9999.我的是 ROS 的主路由 我在 ROS 的防火墙设置端口转发域名+9999 HTTP 能正常访问,但是到 HTTPS 就不行了 ,所以也不知道是哪里出错了!!!
    dreamage
        38
    dreamage   291 天前
    9999http 通 https 不通 那就是 nginx 证书+反代配错了呗
    lancolor9812
        39
    lancolor9812   291 天前
    @dreamage 这个反代我就是照着教程来的呀 nginx 证书到是没有配置过 所以也不知道咋弄
    lychs1998
        40
    lychs1998   291 天前
    bitwarden https 不通是指网页无法登录还是完全就是网络连接超时?

    如果是无法登录就是 https 证书问题,估计是配置错了证书,nginx 的 ssl_certificate 对应的文件应该是 fullchain.pem 。我之前部署 bitwarden 是因为这个出错。

    如果是连接超时估计是没配置 bitwarden 反向代理到 443 端口。
    lancolor9812
        41
    lancolor9812   291 天前
    @lychs1998 嗯… 无法访问此页面似乎 bitwarden. *****.xyz 关闭了连接
    请尝试:
    正在检查连接
    检查代理和防火墙
    运行 Windows 网络诊断
    ERR_CONNECTION_CLOSED


    HTTP 打开是正常的 但是用 HTTPS 打开就是这个错误 !!!
    SgtPepper
        42
    SgtPepper   223 天前 via Android
    路由器端口转发的内网端口设成是你在群晖反代中给 bitwarden 设置的外网端口,而不是 bitwarden 的内网端口。
    关于   ·   帮助文档   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2358 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 20ms · UTC 00:57 · PVG 08:57 · LAX 17:57 · JFK 20:57
    ♥ Do have faith in what you're doing.