V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
shooter2020
V2EX  ›  MacBook Pro

Python 做数值计算,新款 mbp 安装 anaconda 是 arm 版吗?

  •  
  •   shooter2020 · 83 天前 · 1411 次点击
    这是一个创建于 83 天前的主题,其中的信息可能已经有所发展或是发生改变。
    新机还没到,也没用过 m1 ,提前了解下,谢谢
    10 条回复    2021-11-01 18:47:51 +08:00
    dddd1007
        1
    dddd1007  
       83 天前
    用 miniforge 代替 anaconda 配环境,安装的是 arm 版。用到现在基本上没问题,numpy ,pandas ,scipy ,sklearn 都没有遇到 bug
    shooter2020
        2
    shooter2020  
    OP
       83 天前
    @dddd1007 谢谢,明白了
    idlerlestat
        3
    idlerlestat  
       83 天前
    mambaforge 也可以,下载包的速度快了不少
    shooter2020
        4
    shooter2020  
    OP
       83 天前
    @idlerlestat 下载的包是 arm 的还是 intel 在转译的?
    wyq977
        5
    wyq977  
       83 天前
    @shooter2020 conda-forge 的 numpy ,scipy 之类的早就已经有 arm 版的了 一些用的少的和旧的 可能会自己 build 或者 pip 安装
    shooter2020
        6
    shooter2020  
    OP
       83 天前
    @wyq977 好的,谢谢你
    dhou45
        7
    dhou45  
       83 天前
    @dddd1007 大佬问一句, 我的新 Mac 到了之后检查 python 版本, 发现是 3.8.9, 查 https://isapplesiliconready.com/ 上面写的是 python3.9 才支持 silicon. 我也没有装 rosetta, 所以这是什么情况? 不支持 silicon 的 python3.8.9 如何可以在没有 rosetta 的 Mac 上运行的.
    https://i.loli.net/2021/10/30/bk9pQidt23fquzh.png
    zhusimaji
        8
    zhusimaji  
       83 天前 via iPhone
    @dhou45 这个是 Mac 系统自带的,你也不要修改,直接去重新安装一个使用 homebrew 或者 conda 都行
    arthurire
        9
    arthurire  
       82 天前
    个人推荐 mambaforge 速度很快
    #3 也提到了
    huzhikuizainali
        10
    huzhikuizainali  
       81 天前
    @dddd1007 如果调用老版本的三方包有问题么?运行会不会报错?
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1544 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 20ms · UTC 00:37 · PVG 08:37 · LAX 16:37 · JFK 19:37
    ♥ Do have faith in what you're doing.