首页   注册   登录

Kilerd

一个宅在家里的网瘾少年
  •   V2EX 第 81626 号会员,加入于 2014-11-14 23:29:17 +08:00,今日活跃度排名 1877
    已屎,有事烧纸。 bz2lsZXJkL
    Kilerd 最近回复了
    某某同学,请独立完成 SQL 课程相关作业。
    20 小时 39 分钟前
    回复了 locktionc 创建的主题 奇思妙想 [App 创意] 今后会有不少人把信息发到区块链上
    我想知道那次的在比特币交易记录附录那里贴上 child porn 的后续怎样了。
    1 天前
    回复了 metrue 创建的主题 分享创造 小对话支持 Github 了
    This page is using an outdated version of React.
    如果用 rust 的思想来讲的话,某些内容满足了 Copy Trait, 所以内部修改不影响外部,最直观的表现就是传参前后的变量没有直接关系。
    然而实际上 in python, everything is an object. 所以都是传引用。
    内容太简单。
    你指出的数字例外,不过只是 Python 对小整数的内存优化而已。

    PS:大神不要喷我。
    家里网络没有公网 IP,玩不了,不然还是想进去玩玩的。
    如果可以以 wifi 拨打电话才厉害。
    3 天前
    回复了 xxbing 创建的主题 Python import requests 出错,搜了很多,没解决,求教.
    Requirement not upgraded as not directly required: urllib3<1.23,>=1.21.1 in d:\p
    ython27\lib\site-packages (from requests) (1.22)

    首先 requests 里面要求 urllib3 要符合这个条件<1.23,>=1.21.1



    D:\Python27\lib\site-packages\requests\__init__.py:80: RequestsDependencyWarning
    : urllib3 (1.9.1) or chardet (3.0.4) doesn't match a supported version!
    你的报错信息是这个。证明安装的 urllib3 是 1.9.1 版本。

    所以出错啊。

    解决方法:
    1 用官方源重装试试。先 pip uninstall requests urllib3

    2 手动升级 urllib3

    3 试下用 virtualenv / pipenv / pyenv 隔离 py 环境


    其实这个问题主要的发生场景是 有一个 package 依赖于 urllib3 较早版本,然后你再安装 requests 的时候会导致依赖冲突,就只有一个 package 可以用了。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   3044 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.0 · 8ms · UTC 03:03 · PVG 11:03 · LAX 20:03 · JFK 23:03
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1