V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
ansheng
V2EX  ›  Ubuntu

刚装了个 Ubuntu,请问有什么比较犀利的软件推荐呢?

  •  
  •   ansheng · 2016-10-22 20:31:19 +08:00 · 6845 次点击
    这是一个创建于 2032 天前的主题,其中的信息可能已经有所发展或是发生改变。

    折腾了半天,表示 Google 浏览器不能使用 flash player ,视频都不能看。

    69 条回复    2017-01-06 22:38:38 +08:00
    contactfront
        1
    contactfront  
       2016-10-22 20:53:01 +08:00
    好奇楼主看的是哪个视频网站
    tyzZ001
        2
    tyzZ001  
       2016-10-22 21:26:58 +08:00
    下载个 flash 插件就可以了。
    zhuangzhuang1988
        3
    zhuangzhuang1988  
       2016-10-22 21:32:25 +08:00 via iPad
    1. 格式化 2. 怪怪 windows
    zhuangzhuang1988
        4
    zhuangzhuang1988  
       2016-10-22 21:32:40 +08:00 via iPad
    乖乖
    rogerchen
        5
    rogerchen  
       2016-10-22 21:32:56 +08:00
    楼主你确认你 chrome://plugins/ 里边没有 flash?
    mozutaba
        6
    mozutaba  
       2016-10-22 21:33:15 +08:00
    chromium
    bsns
        7
    bsns  
       2016-10-22 21:35:54 +08:00
    i'm very angry,一派胡言, chrome 自带 flash ,只有 chromium 需要装!
    mdzz
        8
    mdzz  
       2016-10-22 21:37:45 +08:00
    你可能需要 pepperflashplugin-nonfree
    mashpolo
        9
    mashpolo  
       2016-10-22 21:43:23 +08:00
    shadowsocks-qt 很需要
    ansheng
        10
    ansheng  
    OP
       2016-10-22 21:54:33 +08:00
    @mashpolo 表示第一个装的就是这个,要不然没梯子
    ansheng
        11
    ansheng  
    OP
       2016-10-22 21:55:43 +08:00
    @mdzz

    ```
    2016-10-22 21:55:23 (1.82 MB/s) - 已保存 “/tmp/pepperflashplugin-nonfree.5XwjlbVJhI/google-chrome-stable_54.0.2840.71-1_amd64.deb ” [45532350/45532350])

    mv: 无法获取'unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so' 的文件状态(stat): 没有那个文件或目录
    ```
    ansheng
        12
    ansheng  
    OP
       2016-10-22 21:56:25 +08:00
    @bsns
    @rogerchen

    Adobe Flash Player - 版本: 23.0.0.185
    Shockwave Flash 23.0 r0
    名字: Shockwave Flash
    说明: Shockwave Flash 23.0 r0
    版本: 23.0.0.185
    位置: internal-not-yet-present
    类型: PPAPI (进程外插件)
    停用
    MIME 类型:
    MIME 类型 说明 文件扩展名
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    停用 始终允许运行
    ansheng
        13
    ansheng  
    OP
       2016-10-22 21:56:34 +08:00
    @contactfront 腾讯视频
    hailinzeng
        14
    hailinzeng  
       2016-10-22 21:59:15 +08:00
    sudo apt-get install flashplugin-installer
    hailinzeng
        15
    hailinzeng  
       2016-10-22 22:00:11 +08:00
    或者
    sudo apt install adobe-flashplugin
    php7
        16
    php7  
       2016-10-22 22:00:48 +08:00
    @ansheng 腾讯视频,确实无法播放,放弃吧
    ansheng
        17
    ansheng  
    OP
       2016-10-22 22:00:51 +08:00
    [email protected]:~$ sudo apt-get install flashplugin-installer
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树
    正在读取状态信息... 完成
    flashplugin-installer 已经是最新版 (11.2.202.637ubuntu0.16.04.1)。
    升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
    [email protected]:~$ sudo apt install adobe-flashplugin
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树
    正在读取状态信息... 完成
    没有可用的软件包 adobe-flashplugin ,但是它被其它的软件包引用了。
    这可能意味着这个缺失的软件包可能已被废弃,
    或者只能在其他发布源中找到

    E: 软件包 adobe-flashplugin 没有可安装候选
    ansheng
        18
    ansheng  
    OP
       2016-10-22 22:01:19 +08:00
    @php7 真的假的,擦,我就只有腾讯视频 VIP 啊。。。。这尼玛
    php7
        19
    php7  
       2016-10-22 22:02:11 +08:00
    @ansheng 我也是,为看青云志,已放弃 ubuntu
    ansheng
        20
    ansheng  
    OP
       2016-10-22 22:02:54 +08:00
    @php7 刚试了下,不能播放所有的视频
    sylecn
        21
    sylecn  
       2016-10-22 22:05:08 +08:00 via Android
    为什么有人说腾讯视频不能播?我这里 debian chrome 和 Firefox 两个都是一直可以播的。主流视频网站全部可以。

    chrome 是自带 flash 的。 firefox 需要去 Adobe 网站下载 tar.gz 包获取一个 so 文件,放到适合的目录。
    ansheng
        22
    ansheng  
    OP
       2016-10-22 22:06:18 +08:00
    @sylecn 我之前装 Ubuntu 都是好好的,不知道这次为什么就成悲剧了,哎,算了吧,反正 firefox 浏览器,上网就用 GOOG 吧。
    keysona
        23
    keysona  
       2016-10-22 22:12:37 +08:00   ❤️ 5
    arch 大法好。

    建议楼主双系统。

    然后,

    终端, zsh + oh my zsh

    游览器, chrome , firefox

    ```
    google-chrome-stable --proxy-server="socks5://127.0.0.1:1080"
    ```

    shadowsocks ,命令行版,方便弄成服务。开机自启。

    mentohust ,若还在校并且使用锐捷。

    privoxy ,转发 socks5 为 http ,方便其他软件使用。

    proxychains ,代理工具,强制命令使用配置的代理。

    ```
    proxychains apt-get update
    ```



    dropbox ,同步网盘。

    输入法, fcitx , fcitx rime 。

    图标包, numix circle theme ?

    编辑器, sublime , vscode 或者 atom 。

    ide , jetbrains 全家桶。

    游戏, steam , minecraft 。



    可以尝试下平铺窗口管理器, awesome , i3 之类的。适合多屏显示。
    dogsteve
        24
    dogsteve  
       2016-10-22 22:22:30 +08:00 via Android
    x13945
        25
    x13945  
       2016-10-22 22:30:24 +08:00 via Android
    php7
        26
    php7  
       2016-10-22 22:34:10 +08:00
    @ansheng 本来就是都不能播放,不过换 opera 还是什么的,好像可以播放
    为了 YY 、百度云和腾讯视频,我已放弃了

    另外求推荐个 ubuntu ,可录 web 视频的或下载 web 视频的软件
    我下载 yy 神曲和回放用
    daya
        27
    daya  
       2016-10-22 22:35:32 +08:00 via Android
    @keysona Arch 不适合追求稳定的人使用
    Khlieb
        28
    Khlieb  
       2016-10-22 22:37:58 +08:00 via Android
    ChinaDNS 值得拥有
    lengxx
        29
    lengxx  
       2016-10-22 22:52:38 +08:00 via Android
    chrome54 默认没有安装 flash
    到 chrome://components/ ,在里面找到 flash player 一项,点击更新,这样你的 chrome 会自动下载 flash 插件
    ansheng
        30
    ansheng  
    OP
       2016-10-22 22:59:56 +08:00
    @lengxx

    Adobe Flash Player - 版本: 0.0.0.0
    状态 - 正在检查
    检查是否有更新

    然后就卡在这儿了。
    qwer1234asdf
        31
    qwer1234asdf  
       2016-10-22 23:03:02 +08:00
    sudo apt-get install -y vim git gdebi python-pip axel tsocks httpie shutter mysql-client mysql-server mysql-workbench htop eclipse ipython
    你值得拥有。。
    lengxx
        32
    lengxx  
       2016-10-22 23:03:46 +08:00 via Android
    @ansheng 可能需要翻墙
    d7101120120
        33
    d7101120120  
       2016-10-22 23:04:19 +08:00
    试试在 chrome://plugins/选中 始终允许运行。
    sylecn
        34
    sylecn  
       2016-10-22 23:05:26 +08:00 via Android   ❤️ 1
    忘记推荐其它软件了。我写过一篇文章专门讲 Linux 软件。

    Software that I use in Linux
    http://blog.emacsos.com/linux-software.html
    skydiver
        35
    skydiver  
       2016-10-22 23:11:56 +08:00 via iPad
    最新版 chrome 已经不自带 flash 了,需要去官网下载 ppapi 版本的 flash 插件然后解压缩到安装目录。

    To use the PPAPI "PepperFlash" flash plugin, download it here:
    https://get.adobe.com/flashplayer/otherversions/

    Choose Linux 64-bit, FP 22.0 (or later) for other Linux 64-bit, PPAPI.

    You will then have flash_player_ppapi_linux.x86_64.tar.gz. Unpack it into /usr/lib64/chromium-browser/PepperFlash/. Then, restart chromium. You should see Adobe Flash Player in chrome://plugins.
    reus
        36
    reus  
       2016-10-22 23:14:17 +08:00
    用深度 linux ,不折腾
    或者 Arch ,不折腾
    imNull
        37
    imNull  
       2016-10-22 23:16:10 +08:00 via Android
    输入法,我觉得搜狗挺好用的 http://pinyin.sogou.com/linux/

    office , wps 也挺好用的
    zhidian
        39
    zhidian  
       2016-10-22 23:23:50 +08:00
    这种时候不应该严肃地给 B 站打个广告吗? B 站不用 flash~!
    SCaffrey
        40
    SCaffrey  
       2016-10-22 23:27:06 +08:00 via iPad
    teeworlds
    Mikewu
        41
    Mikewu  
       2016-10-22 23:28:05 +08:00
    腾讯视频不是支持 h5 的吗?为什么播放不了?
    ansheng
        42
    ansheng  
    OP
       2016-10-22 23:29:18 +08:00
    @reus 深度感觉好丑
    ansheng
        43
    ansheng  
    OP
       2016-10-22 23:29:31 +08:00
    @SCaffrey 不玩游戏。
    lengxx
        44
    lengxx  
       2016-10-22 23:31:01 +08:00 via Android
    我只是日常用,推荐下网易云音乐吧,嗯, linux 版
    ansheng
        45
    ansheng  
    OP
       2016-10-22 23:37:36 +08:00
    @lengxx 网易已装
    Vizogood
        46
    Vizogood  
       2016-10-22 23:40:51 +08:00 via Android
    哈哈,你会回 win 的,和我去年一样
    ansheng
        47
    ansheng  
    OP
       2016-10-22 23:45:27 +08:00
    @Vizogood 我就是回了 win 又回来的。
    bsns
        48
    bsns  
       2016-10-22 23:49:20 +08:00

    v 站的人说 linux 不能能用 gpu ,不能用驱动,网速慢,现在又说不能看腾讯视频,你们啊,还是要学习!
    hiluluke
        49
    hiluluke  
       2016-10-22 23:51:23 +08:00
    guake
    a62527776a
        50
    a62527776a  
       2016-10-22 23:52:02 +08:00
    steam hoho
    keysona
        51
    keysona  
       2016-10-22 23:54:27 +08:00
    @daya

    个人觉得使用 wm + lts 内核, arch 也可以稳定的,比 ubuntu 之类的还要稳定。
    tyfulcrum
        52
    tyfulcrum  
       2016-10-23 00:05:09 +08:00
    新人的话如果只是追求日常使用稳定还不用 Ubuntu 的话 openSUSE 显然是最靠谱的选择。 Arch 新手需要折腾学习。
    7654
        53
    7654  
       2016-10-23 00:19:05 +08:00
    pip3 install you-get ,远离 flash
    Aria2
    ……
    muziki
        54
    muziki  
       2016-10-23 00:21:19 +08:00 via iPhone
    上面给新人推 arch 。。
    linuxmint 高枕无忧,熟悉了再切换到 arch
    efil
        55
    efil  
       2016-10-23 01:20:16 +08:00 via Android
    自己使用 chrome (直接去官网下的) 不是 chromium 中,前端时间遇到过不能播放腾讯视频上的视频(资源获取不了),不过现在是能正常观看的
    efil
        56
    efil  
       2016-10-23 01:24:48 +08:00 via Android
    歪个楼,有没有遇到过在 Ubuntu 上使用 XX-Net 时在线看视频时挺大概率会造成死机
    ansheng
        57
    ansheng  
    OP
       2016-10-23 01:52:27 +08:00
    @efil 之前都是好好地,也就这次有点坑,
    php7
        58
    php7  
       2016-10-23 01:59:50 +08:00
    @zhidian B 站毛版权都没有 手动斜眼
    wun
        59
    wun  
       2016-10-23 02:03:54 +08:00
    @php7 还是有合作的
    akinoneko
        60
    akinoneko  
       2016-10-23 07:45:40 +08:00 via iPhone
    @php7 腾讯视频已经支持 h5 了
    onice
        61
    onice  
       2016-10-23 11:26:22 +08:00   ❤️ 1
    网络上传下载: filezilla
    文件加密: veracrypt
    网络抓包: wireshark
    网络探测: nmap
    网络嗅探: ettercap
    梯子: shadowsocks-qt
    播放器: VLC Media player
    桌面便签: tomboy
    护眼: redshift
    通用编辑器: visual studio code (本用 sublime text 很好,但 linux 下输入法支持不好)
    直播: obs
    抓网络中的图片流: driftnet ,可以配合 ettercap 使用
    图像处理: gimp
    密码管理: Keepass , Lastpass
    防火墙规则管理: Gufw Firewall (如果比较熟悉 ufw 命令,可以不用安装这个图形界面)
    网络流量监视: nethogs , iftop

    还有个小问题,就是有些应用程序不会显示桌面托盘图标,不知道现在这个问题官方解决没有,如果没有解决可以试试: https://github.com/GGleb/indicator-systemtray-unity

    上面那些网络管理工具是可选的。不过建议安装上,很有用。例如去咖啡厅,就可以探测下网络环境。了解下网络情况心里有个底。

    最后, steam 不要忘记。虽然是 Linux ,但也要娱乐嘛...
    onice
        62
    onice  
       2016-10-23 11:28:24 +08:00
    楼主可以试下 chromium ,安装好自带 flash 。内置的 firefox 需要去 adobe 官网下载 flash player 。
    searene
        63
    searene  
       2016-10-23 11:47:55 +08:00
    arch 没有传说中的那么不稳定,我用 arch 不止一年了,一直滚动升级,基本没出现过问题,而且装软件特别方便,几乎没有 yaourt 找不到的东西, wiki 也要比 ubuntu 的好很多,强烈推荐。

    窗口管理器: i3wm ,配合 conky 可以美化。 https://searene.github.io/2016/10/07/beautify-i3wm/
    字体渲染: infinality
    文本编辑器: vim , gvim
    播放视频: smplayer
    画图: pinta
    下载: aria2c
    IDE : jetbrains 全家桶
    songchao
        64
    songchao  
       2016-10-23 12:58:29 +08:00
    hullopanda
        65
    hullopanda  
       2016-10-23 14:27:41 +08:00
    还没支持 HTML5 的视频站 你还在坚持看~~~
    lianxiaoyi
        66
    lianxiaoyi  
       2016-10-23 14:47:48 +08:00 via Android
    一派胡言!老衲已经在 ubuntu 纵横 3 年,从没见过没有 flash 的谷歌浏览器!
    way2exp
        67
    way2exp  
       2016-10-23 15:39:35 +08:00
    @lianxiaoyi 同意,只发现过之前 chrome 自带的 flash 没声音的
    xcc880
        68
    xcc880  
       2016-10-24 09:04:11 +08:00
    @efil 没有
    max891121500
        69
    max891121500  
       2017-01-06 22:38:38 +08:00
    系统中的 firefox 自带 flash-player
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3850 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 33ms · UTC 03:55 · PVG 11:55 · LAX 20:55 · JFK 23:55
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.