V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
therethere9
V2EX  ›  问与答

感觉越来越多的 app 不支持 android 4.4 的手机了

  •  
  •   therethere9 · 2019-09-08 17:15:13 +08:00 · 3855 次点击
    这是一个创建于 449 天前的主题,其中的信息可能已经有所发展或是发生改变。
    24 条回复    2019-11-10 18:21:16 +08:00
    also24
        1
    also24   2019-09-08 17:19:05 +08:00 via Android
    Android KitKat ( 4.4 )是 Google 继 Android Jelly Bean 之后开发的 Android 移动操作系统,于 2013 年 10 月正式发布。

    2013 年 9 月 10 日,苹果公司在 2013 秋季新品发布会上正式提供 iOS 7 下载更新。
    love
        2
    love   2019-09-08 17:22:00 +08:00   ❤️ 2
    android 开发者太难了,这是要测试多少版本啊
    winterbells
        3
    winterbells   2019-09-08 17:23:41 +08:00 via Android
    我们现在最低支持 23。。
    janus77
        4
    janus77   2019-09-08 17:24:30 +08:00 via iPhone
    你先去买一台 4.4 的新机再说
    loginbygoogle
        5
    loginbygoogle   2019-09-08 17:24:51 +08:00 via Android
    没必要兼容 API21 以下的应用
    echo314
        6
    echo314   2019-09-08 17:37:28 +08:00 via iPhone
    你该怪你的手机厂商没有升级系统。
    ddup
        7
    ddup   2019-09-08 17:59:09 +08:00 via Android
    太老了
    azh7138m
        8
    azh7138m   2019-09-08 18:18:00 +08:00
    现在好多软件要求 iOS 10,对标过来应该是 Android 7
    id7368
        9
    id7368   2019-09-08 18:24:26 +08:00 via iPhone
    4.1.2 表示大部分都装不了了
    nieyujiang
        10
    nieyujiang   2019-09-08 19:22:19 +08:00
    这边建议你买个新手机呢
    zhanao1994
        11
    zhanao1994   2019-09-08 19:30:20 +08:00 via Android
    马上都 2020 年了还 4.4 啊 😂
    ssynhtn
        12
    ssynhtn   2019-09-08 19:55:38 +08:00 via iPad
    因为根本就没有这个版本的测试机了
    我手头上最低版本的是 5.1 的 moto x 二代,当时出厂是 4.4 的系统,配置是骁龙 801 和 2g 内存
    现在这这台手机上运行微信根本没法愉快地使用,一台国内的手机如果连微信用着都难受,你说其它 app 有必要适配它吗?
    myth
        13
    myth   2019-09-08 19:58:40 +08:00 via Android
    微信好像最低支持 4.4
    yukiww233
        14
    yukiww233   2019-09-08 20:09:06 +08:00
    我司已经没 4.4 的测试机了,所以 4.4 是随缘适配
    一年前我就在提改 minsdk 放弃 4.4 了
    fatelight
        15
    fatelight   2019-09-08 20:24:16 +08:00
    别说 4.4、连 5.0 都不想支持。
    fatelight
        16
    fatelight   2019-09-08 20:30:42 +08:00
    @ssynhtn 对,一个手机如果连支付宝,微信,淘宝都无法愉快使用的话,那么这个用户大多不是目标用户。现在基本 3G 内存手机勉强能用。而 3G 内存大概是 5.0 或者 6.0 的出厂系统。用超老的手机,难道期待能为软件订阅付费?
    z919126592
        17
    z919126592   2019-09-08 20:32:40 +08:00 via Android
    @fatelight 事实上这三个毒瘤要能流畅运行还真的要 835 左右同级才行
    Lin0936
        18
    Lin0936   2019-09-08 20:34:50 +08:00 via Android
    可能 Android 开发者的梦想就是把 minSDK 调到最新 API Level。
    fatelight
        19
    fatelight   2019-09-08 20:40:14 +08:00
    @Lin0936 也不是,大概 3 个版本以内就好了。
    May725
        20
    May725   2019-09-08 21:11:25 +08:00
    这就跟支持 xp 一样,旧版本尽快淘汰是最好了
    Deffi
        21
    Deffi   2019-09-09 09:42:59 +08:00
    给个支持的理由
    NSAtools
        22
    NSAtools   2019-09-09 09:57:03 +08:00
    有些专用设备还是 2.3
    Mavious
        23
    Mavious   2019-09-09 11:27:03 +08:00
    4.4 的手机,早在 2017 年初我就淘汰了=_=
    安卓能撑到现在也是本事
    712e1959
        24
    712e1959   2019-11-10 18:21:16 +08:00 via Android
    一个手机能用 5 年也算是有本事了……
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1170 人在线   最高记录 5268   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 19:52 · PVG 03:52 · LAX 11:52 · JFK 14:52
    ♥ Do have faith in what you're doing.